Package Details: python2-gpapi 0.4.2-1

Git Clone URL: https://aur.archlinux.org/python-gpapi.git (read-only)
Package Base: python-gpapi
Description: Google Play Unofficial Python API
Upstream URL: https://github.com/NoMore201/googleplay-api
Licenses: GPL3
Submitter: fordprefect
Maintainer: fordprefect (lightdot)
Last Packager: fordprefect
Votes: 2
Popularity: 0.088153
First Submitted: 2017-10-07 22:23
Last Updated: 2018-02-01 21:33

Latest Comments

yan12125 commented on 2018-06-24 02:29

Also, pycryptodome is preferred by the author NoMore201: https://github.com/NoMore201/googleplay-api/commit/e1cc147db466515b503d44f8256597c350a6df8d

yan12125 commented on 2018-06-24 02:27

@lightdot: currently gplaycli (a program uses gpapi) does not work out-of-box:

$ gplaycli 
Traceback (most recent call last):
  File "/usr/bin/gplaycli", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3095, in <module>
    @_call_aside
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3079, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 3108, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 570, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 888, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.6/site-packages/pkg_resources/__init__.py", line 774, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'pycryptodome' distribution was not found and is required by gpapi

lightdot commented on 2018-06-23 20:02

Is there a technical reason for this? I don't have a strong preference but I'd like to hear why specifically is this recommended.

yan12125 commented on 2018-06-22 07:45

@fordprefect @lightdot could you fix this package as described by @doskoi?

doskoi commented on 2018-04-08 01:50

The setup.py file explicitly requires pycryptodome instead of pycrypto.

lightdot commented on 2018-01-10 03:41

Hm, the 0.3.2 still seems to report a 0.3.1 version. I get /usr/lib/python3.6/site-packages/gpapi-0.3.1-py3.6.egg-info and the PKG-INFO file contains the "Version: 3.2.1" line.

fordprefect commented on 2017-10-09 08:16

@gillux: thanks, updated. I just determined the deps with namcap in the first place, maybe a bit too sloppy…

gillux commented on 2017-10-09 05:25

Thank you for packaging this! Could you add the run-time dependencies too:
python-crypto python-protobuf python-clint python-requests