Package Details: python2-gpg 1.8.0-2

Git Clone URL: https://aur.archlinux.org/python2-gpg.git (read-only)
Package Base: python2-gpg
Description: Python bindings for gpgme
Upstream URL: https://pypi.python.org/pypi/gpg
Licenses: GPL2+, LGPL2.1+
Submitter: dcbaker
Maintainer: dcbaker
Last Packager: dcbaker
Votes: 5
Popularity: 0.010303
First Submitted: 2017-08-16 16:47
Last Updated: 2017-08-30 17:48

Latest Comments

myops commented on 2018-01-14 08:50

The gpg key is expired.

Fails on i686 with gpgme from archlinux32 with:

gpgme.h:104: Error: CPP #error "GPGME was compiled with _FILE_OFFSET_BITS = 64, please see the section "Largefile support (LFS)" in the GPGME manual.". Use the -cpperraswarn option to continue swig processing. error: command 'swig' failed with exit status 1

dcbaker commented on 2017-12-11 19:07

Yes, the key is still valid. It's signed witha gpg developer's key, not one of the archlinux developer's keys. So you'll need to add the key to your keyring before you can use it to verify,

gpg --recv-keys DD1A52F9DA8C9020

will add it to your keyring.

wvi commented on 2017-12-10 13:24

Is the key still valid as I am getting build error.

==> Validating source files with sha256sums...
    gpg-1.8.0.tar.gz ... Passed
    gpg-1.8.0.tar.gz.asc ... Skipped
==> Verifying source file signatures with gpg...
    gpg-1.8.0.tar.gz ... FAILED (unknown public key DD1A52F9DA8C9020)
==> ERROR: One or more PGP signatures could not be verified!
==> ERROR: Makepkg was unable to build python2-gpg.

dcbaker commented on 2017-08-30 17:46

Oops, you're right about that. I'll update the package, thanks for pointing it out!

GenkiSky commented on 2017-08-30 03:30

Hi, thanks for the package. However in the PKGBUILD, `depends' is assigned to twice: Once to what it should be, and right after that to an empty array. I don't think that second assignment should be there.