Package Details: python2-gudev-git 147.2.1.g780b007-2

Git Clone URL: https://aur.archlinux.org/python2-gudev-git.git (read-only)
Package Base: python2-gudev-git
Description: Python (PyGObject) bindings to the GUDev library
Upstream URL: http://github.com/nzjrs/python-gudev
Licenses: LGPL3
Conflicts: python-gudev, python2-gudev
Provides: python-gudev, python2-gudev
Replaces: conduit-svn
Submitter: Muflone
Maintainer: Muflone
Last Packager: Muflone
Votes: 43
Popularity: 0.000008
First Submitted: 2013-08-08 15:21
Last Updated: 2015-06-13 16:11

Required by (2)

  • arista (requires python2-gudev)
  • luciole (requires python2-gudev)

Sources (3)

Latest Comments

Muflone commented on 2013-08-08 16:37

Package renamed from python-gudev-git to python2-gudev-git
PKGBUILD updated

onny commented on 2013-08-07 00:14

Please update according to https://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines#A_sample_Git_PKGBUILD and rename package to python2-gudev-git

khampf commented on 2012-09-02 18:28

./configure: line 12175: syntax error near unexpected token `PYGOBJECT,'
./configure: line 12175: `PKG_CHECK_MODULES(PYGOBJECT, pygobject-2.0 >= 2.18.0)'

reztho commented on 2011-06-05 18:23

Here it is a fixed PKGBUILD made by me: http://pastebin.com/DFaqWZPE

This pastebin link expires in a month. Be sure to get it.

yangtsesu commented on 2011-04-16 14:36

File "/usr/share/pygobject/2.0/codegen/codegen.py", line 429
except argtypes.ArgTypeError, ex:
^
SyntaxError: invalid syntax
make: *** [gudev.c] 错误 1
make: *** 正在等待未完成的任务....
gudevmodule.c:24:1: warning: return type defaults to 'int' [-Wreturn-type]
gudevmodule.c:24:1: warning: no previous prototype for 'DL_EXPORT' [-Wmissing-prototypes]
gudevmodule.c: In function 'DL_EXPORT':
gudevmodule.c:25:1: error: expected declaration specifiers before 'initgudev'
gudevmodule.c:43:1: error: expected '{' at end of input
gudevmodule.c:43:1: warning: control reaches end of non-void function [-Wreturn-type]
make: *** [gudevmodule.lo] 错误 1

mathieu.clabaut commented on 2011-03-04 10:51

This package sould be build with python2 :


depends=('python2')
...

PYTHON=python2 ./configure --prefix=/usr