Package Details: python2-guessit 2.1.4-1

Git Clone URL: (read-only)
Package Base: python2-guessit
Description: a library for guessing information from video filenames
Upstream URL:
Licenses: GPL3
Replaces: python2-guessit-rc
Submitter: nicoulaj
Maintainer: cgirard
Last Packager: cgirard
Votes: 21
Popularity: 0.006855
First Submitted: 2012-06-17 10:33
Last Updated: 2017-06-05 15:01

Latest Comments

highway commented on 2016-09-10 01:23

back in business! :)

cgirard commented on 2016-07-27 09:42

BTW, older version of dateutil are available there:

highway commented on 2016-07-27 01:43

the holdup is with dateutil functionality, flexget will be unusable until the issue is fixed.

highway commented on 2016-07-24 12:55

there is an issue opened at their github if anyone wants to comment/upvote to show support and urgency

highway commented on 2016-07-17 12:48

@boennhoff i am in the same boat and would love an answer. who would i have to contact upstream? the package owner at pypi?

boennhoff commented on 2016-07-13 09:17

I can't update this package since the dependency dateutil<2.5.2 is not available anymore... @cgirard is right, upstream also has this "lock", but that fact still makes this package useless on arch.

How do others solve this problem?

cgirard commented on 2016-05-17 09:34

This package is up to date and the dependencies are aligned with upstream. If you are not happy, bug upstream, not me.

highway commented on 2016-05-16 21:09

how long until we can flag this as out of date? @kazuo @cgirard

kazuo commented on 2016-05-09 01:07

@cgirard when using versioned deps you need to coordinated releases with the others maitainers, but you can't even coordinate releases with yourself. python2-guessit is at 2.0.5 but flexget-git needs 2.0.4!

kazuo commented on 2016-05-09 00:54

@cgirard can you please stop versioning each dep of every package you touch?

highway commented on 2016-05-08 15:33

err just the older version of dateutil? the current version is 2.5.3

highway commented on 2016-05-08 13:14

is there a reason that this package requires older versions of dateutil and rebulk?

cgirard commented on 2016-05-06 12:31

Adopted and updated

petecan commented on 2016-05-05 17:11

I do not use subliminal or guessit anymore, so it is better that someone else takes care of this. I have just disowned the package.

A python2-guessit-010 package sounds like the way to go, although it seems to me we might not be far from a new subliminal release.

cgirard commented on 2016-05-05 16:53

I am not using subliminal, I have not checked past the PR. You could always upload a python2-guessit-010 package for subliminal.

Your call. As I am maintaining the python2-guessit-rc (which is not RC anymore) meanwhile, it won't be extra load for me.

petecan commented on 2016-05-05 16:47

Unless I'm missing something, that commit to subliminal was merged on the develop branch only and has not made it to a pypi release nor to master yet, let alone to the subliminal packages in the aur.

@cgirard do you want to take over the maintenance of this package?

cgirard commented on 2016-05-03 15:37

This commit has been merged 3 months ago...

petecan commented on 2016-01-30 12:09

Guessit2 is out, but it breaks the API. I will update the package as soon as subliminal sees a new release with these changes on it, hopefully soon enough:

petecan commented on 2014-05-07 08:53

All sorted, thanks katta.

katta commented on 2014-05-07 08:44

I forget a dependency for cli interface in previous file:

katta commented on 2014-05-05 09:37

When I try to import guessit module I receive this error:

Traceback (most recent call last):
File "/usr/bin/guessit", line 5, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/", line 2749, in <module>
working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/site-packages/", line 444, in _build_master
File "/usr/lib/python2.7/site-packages/", line 725, in require
needed = self.resolve(parse_requirements(requirements))
File "/usr/lib/python2.7/site-packages/", line 628, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: stevedore

I solved updating to 0.7.1.

Please update!

fede commented on 2013-11-13 14:53

Version 0.6.2 PKGBUILD:

# Maintainer: Julien Nicoulaud <>
# Source:
pkgdesc="A library for guessing information from video files."

package() {
cd "${srcdir}/guessit-${pkgver}"
python2 install --root="$pkgdir/" --optimize=1

acieroid commented on 2013-10-31 09:09

Latest version is 0.6.1, could you update this package? (It is just a matter of updating the version number and the md5sum.) Many thanks.

nicoulaj commented on 2012-11-18 18:11

@Cilyan: It's fixed now.

nicoulaj commented on 2012-10-25 19:25

@Cylan: the python-guessit is misnamed, it also provides guessit for python2, that's why it conflicts with this one. The python-guessit package must be fixed before I can remove provides+conflicts.

Cilyan commented on 2012-10-25 19:00

Hi nicoulaj,
you should not conflict with python-guessit as your package should provide guessit for python2 whereas python-guessit should provide it for python 3 and both can be installed on the same system.
Moreover, version 0.5.2 is out.