Package Details: python2-imaging 1.1.7-13

Git Clone URL: https://aur.archlinux.org/python2-imaging.git (read-only)
Package Base: python2-imaging
Description: PIL. Provides image processing capabilities for python
Upstream URL: http://www.pythonware.com/products/pil/index.htm
Licenses: custom:"pil"
Conflicts: pil
Provides: pil=1.1.7
Replaces: pil
Submitter: keenerd
Maintainer: None
Last Packager: yan12125
Votes: 27
Popularity: 1.734456
First Submitted: 2014-01-08 21:41
Last Updated: 2016-02-17 15:00

Dependencies (8)

Required by (41)

Sources (2)

Latest Comments

yan12125 commented on 2016-08-09 04:05

Disowned - I use python2-pillow now instead of python2-imaging.

yan12125 commented on 2016-02-17 15:02

Thanks @mischka Should be fixed with version 1.1.7-13. Both freetype2 and freetype2-ubuntu works for me.

mischka commented on 2016-02-11 05:08

Thank you @Alister.Hood, that worked for me.

@yan12125, the error I was getting was:
_imagingft.c:73:31: fatal error: freetype/fterrors.h: No such file or directory
compilation terminated.

I'm using freetype2-ubuntu, so that's probably why.

Edit: Actually that's probably not why, but I should probably start using regular freetype2 again anyway.

yan12125 commented on 2015-12-24 17:57

@Alister.Hood What kind of errors did you get? The build works for me with freetype2 2.6.2-1

Alister.Hood commented on 2015-12-23 21:41

I was getting that error unless I did this:
cd /usr/include
ln -s freetype2 freetype

yan12125 commented on 2015-12-19 07:14

Adopt and updated. Thanks @daniel_shub!

daniel_shub commented on 2015-11-16 18:26

@akovia I just commented out the line of the PKGBUILD that applies the patch (line 34) by putting a # sign at the beginning of the line.

akovia commented on 2015-11-16 17:52

Ended up getting it installed by modifying the patch file to

35c35
< #include <freetype/freetype.h>
---
> #include <freetype2/freetype/freetype.h>
73c73
< #include <freetype/fterrors.h>
---
> #include <freetype2/freetype/fterrors.h>

akovia commented on 2015-11-16 17:05

Same here,
_imagingft.c:73:32: fatal error: freetype2/fterrors.h: No such file or directory
compilation terminated.

Unfortunately I don't know how to build it without the patch. Any word on this?

psyxcience commented on 2015-10-17 09:21

I have the same problem as daniel_shub and this causes at least one other applications to break (e.g., PsychoPy).
(4.2.3-1-ARCH i686)

daniel_shub commented on 2015-10-09 15:44

I failed to build this in a clean chroot

_imagingft.c:73:32: fatal error: freetype2/fterrors.h: No such file or directory
compilation terminated.
error: command 'gcc' failed with exit status 1

If I do not apply the patch, the package builds fine. My guess is freetype2 has been updated, but I cannot find the change in the change log.

jyantis commented on 2015-05-02 19:32

nocturne111: Thanks and fixed.

nocturne111 commented on 2015-05-02 16:46

Someone typed in PKGBUILD 'amrv6h' instead of 'armv6h' so it breaks in RaspberryPi, correct it manually and hope somene will notice it and correct it at source too.

jyantis commented on 2015-04-26 15:16

I just adopted this package. The requested updates below have been implemented. Please let me know if anything else.

korrode commented on 2015-03-25 14:59

patch is part of the base-devel package group, which users should have already installed before trying to use AUR[1], and thus usual convention is it does not need to be a dependency.

As for adding arm arch; the package is orphaned, so you can adopt it and add it yourself.

[1] https://wiki.archlinux.org/index.php/Arch_User_Repository#Getting_started

korrode commented on 2015-03-25 14:59

patch is part of the make-devel package group, which users should have already installed before trying to use AUR[1], and thus usual convention is it does not need to be a dependency.

As for adding arm arch; the package is orphaned, so you can adopt it and add it yourself.

[1] https://wiki.archlinux.org/index.php/Arch_User_Repository#Getting_started

alutke commented on 2015-03-25 11:48

Please add armv7h (pi 2) as arch
Pleaseadd patch as a dependancy

Thanks!
Alex

anntzer commented on 2015-03-03 04:49

Currently conflicts with python-pillow due to executables with the same name in /usr/bin. Please rename as pilconvert2, pildriver2, etc. as usual.

rackbreaker commented on 2014-10-07 14:22

I'm in a raspberry pi and did not find the packages for " amrv6h " , anyone know how to fix this ? :)

archlinuxomane commented on 2014-04-18 11:05

Also builds on armv5te (Pogoplug v2)

Holodoc commented on 2014-04-04 13:01

Please add 'armv6l' to arch. It compiles sucessfully for my raspberry

korrode commented on 2014-01-27 12:15

Disowning in favour of:
https://aur.archlinux.org/packages/python2-imaging-alt/
Which python2-pillow doesn't attempt to replace every system update.

One can just use in pacman.conf:
IgnorePkg = python2-pillow
and then replacement attempt doesn't occur, but my personal preference is to use an alternate package name

ypoluektovich commented on 2014-01-14 22:03

@DrTebi: I have freetype2 version 2.5.2-1, the same as in the repos: https://www.archlinux.org/packages/extra/x86_64/freetype2/

DrTebi commented on 2014-01-14 21:42

@ypoluektovich:
If you upgrade freetype2, you won't get that error anymore and python2-imaging will build just fine.

ypoluektovich commented on 2014-01-12 01:24

Uploaded 1.1.7-9
Fixes build failure: _imagingft.c:73:31: fatal error: freetype/fterrors.h: No such file or directory
That header is actually in the directory "freetype2", see package "freetype2".

ypoluektovich commented on 2014-01-12 00:44

_imagingft.c:73:31: fatal error: freetype/fterrors.h: No such file or directory