Package Details: python2-liblarch 2.1-2

Git Clone URL: https://aur.archlinux.org/python2-liblarch.git (read-only)
Package Base: python2-liblarch
Description: Python library to easily handle data structure
Upstream URL: https://wiki.gnome.org/action/show/Projects/liblarch
Licenses: LGPL3
Conflicts: python2-liblarch_gtk
Provides: python2-liblarch_gtk
Submitter: Francois_B
Maintainer: Francois_B
Last Packager: Francois_B
Votes: 46
Popularity: 0.000082
First Submitted: 2012-02-25 08:57
Last Updated: 2015-06-13 14:33

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

Frnco commented on 2015-05-26 20:28

Fails to build, two problems in PKGBUILD

1 - Version should be v2.1.
v2.1.0 is reporting as not existing upstream, download fails.

2 - Checksum also changed, the correct now is:
01248CE2E89C4E53720D71895AB4BFC3


With this two changes everything works. :D

izidor commented on 2014-03-30 17:23

There are couple changes:

* Upstream URL was moved: https://wiki.gnome.org/action/show/Projects/liblarch
* Liblarch was moved under GTG's github organization: https://github.com/getting-things-gnome/liblarch
* Liblarch now support Python3 only (package name should be changed/new package required) to python3-liblarch

nextsux commented on 2013-04-07 17:49

I'm unable to upgrade:
==> Starting build()...
[cut]
creating /tmp/yaourt-tmp-nexus/aur-python2-liblarch/pkg/python2-liblarch
error: could not create '/tmp/yaourt-tmp-nexus/aur-python2-liblarch/pkg/python2-liblarch': Permission denied

$ ~/arch-pkg/xkeyboard-config $ ls -dn /tmp/yaourt-tmp-nexus/aur-python2-liblarch/pkg/
d--------- 2 1000 100 40 7. dub 19.47 /tmp/yaourt-tmp-nexus/aur-python2-liblarch/pkg/

Francois_B commented on 2013-04-07 13:29

Upstream moved the source file to github. I fixed the URL and md5sum.

ReStrictOr commented on 2013-04-07 13:06

I get a "Page not found - 404" on the source file.

ReStrictOr commented on 2013-04-07 12:39

I get a "Page not found - 404" on the source file.

Francois_B commented on 2012-11-14 13:50

np. unflaged :)

saimn commented on 2012-11-14 13:00

oups, sorry for the out of date flag, the last version is indeed 2.1.0 but gtg's author seems confused about this version number ;-)
http://linuxfr.org/users/ploum/journaux/sortie-de-gtg-0-3-et-de-liblarch-2-1-1

Francois_B commented on 2012-11-10 17:16

Until gtg is not updated to 3.0, I do not advice to update this package.

shardik commented on 2012-11-10 17:04

failed to update:

error: failed to commit transaction (conflicting files)
python2-liblarch: /usr/lib/python2.7/site-packages/liblarch_gtk/__init__.py exists in filesystem
python2-liblarch: /usr/lib/python2.7/site-packages/liblarch_gtk/__init__.pyc exists in filesystem
python2-liblarch: /usr/lib/python2.7/site-packages/liblarch_gtk/treemodel.py exists in filesystem
python2-liblarch: /usr/lib/python2.7/site-packages/liblarch_gtk/treemodel.pyc exists in filesystem
Errors occurred, no packages were upgraded.

xangelux commented on 2012-06-01 15:18

Yes, it is, sorry for the inconvenience

Francois_B commented on 2012-06-01 03:36

Could you be more specific (paste the output in pastebin)? Please, check that the git version is not installed yet.

xangelux commented on 2012-06-01 00:34

Can't install, complaints of conflicting files, stops me from installing gtg