Package Details: python2-llvmlite-git 0.19.0.dev.r22.g6ac74c8-1

Git Clone URL: https://aur.archlinux.org/python-llvmlite-git.git (read-only)
Package Base: python-llvmlite-git
Description: A lightweight LLVM python binding for writing JIT compilers
Upstream URL: https://github.com/numba/llvmlite
Licenses: BSD
Conflicts: python2-llvmlite
Provides: python2-llvmlite
Submitter: guotsuan
Maintainer: guotsuan
Last Packager: guotsuan
Votes: 2
Popularity: 0.000003
First Submitted: 2014-11-30 03:15
Last Updated: 2017-06-30 18:02

Required by (2)

Sources (1)

Latest Comments

guotsuan commented on 2016-02-19 17:31

@lonaowna: Thanks. I have updated the PKGBUILD include the 'python2-enum34'
And yes, Numba seems to work finally with newest numba code and llvmlite-git based on llvm 3.7!!

mschu commented on 2016-02-19 14:30

With https://github.com/numba/llvmlite/pull/100 merged, this should depend on llvm>=3.7.0 (and python2 version as well).

lonaowna commented on 2016-02-19 12:28

Just found out that Numba works with LLVM 3.7 + python-llvmlite-git + python-numba-git!

lonaowna commented on 2016-02-19 11:39

@guotsuan, thanks. I managed to succesfully build this package.
However, I had to install the 'python2-enum34' package to build it. I think it should be a makedepend.

guotsuan commented on 2016-02-10 15:59

Hi @lonaowna,

I have managed to make the llvmlite work with the LLVM 3.7. However the Numba is still broken because it need to change accordingly too, which have not been done yet.

lonaowna commented on 2016-02-09 16:28

- nevermind, this still is broken with LLVM 3.7 -
https://github.com/numba/llvmlite/pull/100

guotsuan commented on 2016-01-02 22:47

Hi @wendell,

I'm afraid the upstream has not yet support llvm 3.7. Before that happen, I guess it is not possible to build this package without downgrading LLVM.

wendell commented on 2016-01-02 22:07

Anyone have any success building this? I don't want to downgrade LLVM just for this, but is there any other way?