Package Details: python2-matplotlib-noqt 1.5.0-2

Git Clone URL: https://aur.archlinux.org/python2-matplotlib-noqt.git (read-only)
Package Base: python2-matplotlib-noqt
Description: A python plotting library, making publication quality plots
Upstream URL: http://matplotlib.org
Licenses: custom
Submitter: None
Maintainer: pedromj
Last Packager: pedromj
Votes: 3
Popularity: 0.000000
First Submitted: 2011-10-18 19:50
Last Updated: 2015-12-10 09:08

Dependencies (23)

Required by (0)

Sources (1)

Latest Comments

pedromj commented on 2014-11-02 14:29

Which version of GTK+ and python2-gobject do you have?

L1ghtmareI commented on 2014-11-02 10:52

Writes out the following during build:
`Traceback (most recent call last):
File "setup.py", line 155, in <module>
result = package.check()
File "/tmp/yaourt-tmp-alex/aur-python2-matplotlib-noqt/src/matplotlib-1.4.2/setupext.py", line 1729, in check
return super(BackendGtkAgg, self).check()
File "/tmp/yaourt-tmp-alex/aur-python2-matplotlib-noqt/src/matplotlib-1.4.2/setupext.py", line 504, in check
additional_info = self.check_requirements()
File "/tmp/yaourt-tmp-alex/aur-python2-matplotlib-noqt/src/matplotlib-1.4.2/setupext.py", line 1626, in check_requirements
import gtk
File "/usr/lib/python2.7/site-packages/gtk-2.0/gtk/__init__.py", line 45, in <module>
from gtk.deprecation import _Deprecated, _DeprecatedConstant
ValueError: bad marshal data (unknown type code)`

Probably not the package's issue, but of `make` itself.

pedromj commented on 2014-10-23 11:11

Updated, please test.

pedromj commented on 2013-08-21 10:06

Updated, please test. Thank you.

pedromj commented on 2012-11-02 13:59

Maybe, but the only difference with the original is that it does not *require* "QT". In addition to GTK, this package supports other backends (tk and wxpython).

Kwpolska commented on 2012-11-02 13:54

IMO, the name "python2-matplotlib-gtk" is more appropriate.