Package Details: python2-nodeenv 1.2.0-1

Git Clone URL: https://aur.archlinux.org/python-nodeenv.git (read-only)
Package Base: python-nodeenv
Description: Node.js virtual environment builder
Upstream URL: https://github.com/ekalinin/nodeenv
Licenses: BSD
Conflicts: python-nodeenv
Submitter: jackuess
Maintainer: WhyNotHugo
Last Packager: WhyNotHugo
Votes: 1
Popularity: 0.000064
First Submitted: 2015-09-09 09:35
Last Updated: 2017-12-30 04:33

Latest Comments

ImNtReal commented on 2018-09-25 13:16

Updated PKGBUILD for those who need it: https://pastebin.com/zNX77ubc

WhyNotHugo commented on 2018-04-09 14:47

This doesn't install "nodeenv for Python 2 AND 3". This PKGBUILD has two packages, and you can install either of them.

I think the problem is that you just tried to install both after building, but you can build both and install just one.

kotrfa commented on 2016-02-17 10:52

This installs nodeenv for Python 2 AND 3. I was getting conflict error when trying to install it and IMO those two packages shouldn't be marked as conflicting.

If you need only version for Python 3 as me, this edit in PKGBUILD helped:

pkgbase=python-nodeenv
pkgname=(python-nodeenv)
pkgver=0.13.5
pkgrel=0
pkgdesc="Node.js virtual environment builder"
url="https://github.com/ekalinin/nodeenv"
license=("BSD")
arch=('any')
makedepends=('python' 'python-setuptools')
source=("$pkgbase-$pkgver.tar.gz::https://pypi.python.org/packages/source/n/nodeenv/nodeenv-$pkgver.tar.gz")
md5sums=('3589277efa3fd90d6c58e2022de6af62')

package_python-nodeenv() {
depends=('python')
conflicts=('python2-nodeenv')

cd $srcdir/nodeenv-${pkgver}
python setup.py install --root=$pkgdir
install -D -m0644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
}