Package Details: python2-numpy-mkl 1.16.2-1

Git Clone URL: https://aur.archlinux.org/python-numpy-mkl.git (read-only)
Package Base: python-numpy-mkl
Description: Scientific tools for Python compiled with intel mkl
Upstream URL: http://numpy.scipy.org/
Keywords: numpy
Licenses: custom
Conflicts: python2-numpy
Provides: python2-numpy=1.16.2
Submitter: bred
Maintainer: RunAndTumble
Last Packager: RunAndTumble
Votes: 35
Popularity: 1.211454
First Submitted: 2012-08-25 16:55
Last Updated: 2019-02-27 13:56

Required by (555)

Sources (5)

Pinned Comments

RunAndTumble commented on 2019-02-10 02:12

I've updated the package, waiting for 1.16.2 is pointless. One of the tests has to fail, according to github, this is just a bad test, should be removed in 1.16.2. I also plan to add a patch that allows to build scipy-mkl w/o any problems. However, I'm not sure that you can use distutils properly after that.

Latest Comments

1 2 3 4 5 6 Next › Last »

RunAndTumble commented on 2019-02-10 02:12

I've updated the package, waiting for 1.16.2 is pointless. One of the tests has to fail, according to github, this is just a bad test, should be removed in 1.16.2. I also plan to add a patch that allows to build scipy-mkl w/o any problems. However, I'm not sure that you can use distutils properly after that.

RunAndTumble commented on 2019-02-02 13:51

Sorry, Folks, I think we should wait for v1.16.2 A few things seem to be broken, I tried python-numpy from the repo: it has the same issue.

RunAndTumble commented on 2019-01-14 12:43

1.16 is out

petronny commented on 2018-11-22 04:29

1.15.4 is out. Please update it.

petronny commented on 2018-09-30 10:43

1.15.2 is out.

L0ric0 commented on 2018-07-06 18:04

Hi, the build_python.sh fails the sha256sums check.

Please update the checksums.

mys_721tx commented on 2018-06-29 22:20

The version number in .SRCINFO needs to be updated.

Morganamilo commented on 2018-05-21 15:03

Replaces should not be used here, this is an alternative to the original package. That's like having wine-staging replaces wine.

Even if replaces was justified I don't think AUR packages should ever use replaces unless it is copied from an existing repo package.

petronny commented on 2018-05-11 08:36

intel-compiler-base should be a dependency

ImportError: libmkl_rt.so: cannot open shared object file: No such file or directory

dianlujitao commented on 2018-05-02 11:24

To workaround build error with icc 18.0.1 + glibc2.27, uncomment __INTEL_PRE_CFLAGS part and change it to

export __INTEL_PRE_CFLAGS="$__INTEL_PRE_CFLAGS -D__PURE_INTEL_C99_HEADERS__ -D_Float32=float -D_Float64=double -D_Float128=\"long double\" -D_Float32x=_Float64 -D_Float64x=_Float128"

ref: https://software.intel.com/en-us/forums/intel-c-compiler/topic/742701#comment-1921418