Package Details: python2-omniorbpy 4.2.4-1

Git Clone URL: https://aur.archlinux.org/omniorbpy.git (read-only, click to copy)
Package Base: omniorbpy
Description: A CORBA object request broker for C++ and Python.
Upstream URL: http://omniorb.sourceforge.net/
Licenses: LGPL
Conflicts: omniorbpy-omg, pyorbit
Provides: omniorbpy, pyorbit
Replaces: omniorbpy
Submitter: None
Maintainer: gbs
Last Packager: gbs
Votes: 10
Popularity: 0.001346
First Submitted: 2006-11-08 20:20 (UTC)
Last Updated: 2020-04-06 14:21 (UTC)

Latest Comments

1 2 3 Next › Last »

Nim65s commented on 2020-09-08 14:25 (UTC)

Hello,

For info, build the python 3 version fails if python 2 is not available. Maybe we should add a makedepends, or find a way to avoid this dependency at all.

Nim65s commented on 2020-04-06 19:14 (UTC)

This works for me, thanks a lot !

gbs commented on 2020-04-06 14:25 (UTC)

I split the package for Python 3 and 2, please tell if there are any problems.

Nim65s commented on 2020-04-06 13:15 (UTC)

Hi again :)

A 4.2.4 version for python3, with a clean patch is available here: https://github.com/nim65s/aur-omniorbpy

@gbs: what are you intentions for this package ? If you plan to keep this for python2, I can just create another one.

Nim65s commented on 2020-03-01 22:51 (UTC)

Hi,

I still need to get this work in Python 3.

Just removing the 2 is not enough, so I lazily imported patches from robotpkg, tweaked them a bit, and it worked for me. This can still be cleaned, but here are the changes: https://github.com/nim65s/aur-omniorbpy

Nim65s commented on 2019-08-30 12:19 (UTC)

It would be great to update this package to Python 3.

Xyne commented on 2014-10-18 13:03 (UTC)

@vitke, mortbauer The package is orphaned. Nobody is currently maintaining it. If you have a working PKGBUILD, please adopt the package and update it. Regards, Xyne

mortbauer commented on 2014-10-16 12:17 (UTC)

but it compiles perfectly by just chnaging the version and of course the md5sum, here is the updated PKGBUILD is at http://pastebin.com/zUp70YJX

vitke commented on 2014-10-09 10:34 (UTC)

It won't compile with omniorb-4.2.0-1: In file included from ../../modules/pyObjectRef.cc:136:0: /usr/include/omniORB4/internal/giopStream.h: In static member function 'static CORBA::Object* omniPy::UnMarshalObjRef(const char*, cdrStream&)': /usr/include/omniORB4/internal/giopStream.h:336:3: error: 'omni::giopStream::operator omni::giopStrand&()' is private operator giopStrand&(); ^ ../../modules/pyObjectRef.cc:663:37: error: within this context giopStrand& g = (giopStrand&)*gs; ^ ../../modules/pyObjectRef.cc:664:13: error: 'class omni::giopStrand' has no member named 'biDir' if (g.biDir && !g.isClient()) { ^ ../mk/beforeauto.mk:647: recipe for target 'pyObjectRef.o' failed make[1]: *** [pyObjectRef.o] Error 1 make[1]: Leaving directory '/usr/local/src/build/omniorbpy/src/omniORBpy-3.7/build/modules' ../dir.mk:4: recipe for target 'all' failed make: *** [all] Error 1

Xyne commented on 2013-10-28 01:27 (UTC)

I have uploaded a version of this package which removes the conflicts with pyorbit in the official repos. I do not know if the pyorbit files are drop-in replacements but a quick diff did not indicate any significant differences. https://aur.archlinux.org/packages/omniorbpy-pyorbit-compat/