Package Details: python2-pafy-git v0.5.4r20.ga23a227-1

Git Clone URL: https://aur.archlinux.org/python2-pafy-git.git (read-only)
Package Base: python2-pafy-git
Description: Python API for YouTube
Upstream URL: https://pypi.org/project/pafy/
Keywords: python2
Licenses: GPL3
Provides: python2-pafy
Submitter: joposter
Maintainer: joposter
Last Packager: joposter
Votes: 2
Popularity: 0.145326
First Submitted: 2015-07-24 18:00
Last Updated: 2019-03-01 19:18

Required by (4)

Sources (1)

Latest Comments

xiretza commented on 2019-03-03 19:48

Requires python2-setuptools in makedepends: https://wiki.archlinux.org/index.php/Python_package_guidelines#setuptools

joposter commented on 2019-03-01 19:19

no problem, i changed to upstream now. As the previous comments said, the problem was a missing package. Since that exists now i have added that as dependency. I hope this resolves your problem :)

eduruiz commented on 2019-03-01 18:00

@joposter thanks for the clarification! I pointed it out because tizonia depends on this package, but with the current version (0.3.x) it's not usable, if you mind you can take a look in this issue: https://github.com/tizonia/tizonia-openmax-il/issues/566#event-2164204467 where I discuss it further with tizonia maintainer.

What's bad about that youtube-dl dependency? Sorry, I'm kinda noob in this AUR world.

joposter commented on 2019-03-01 17:07

@eduruiz The reason for staying on 0.3.x releases was the added youtube-dl dependency. The release mentioned the branch 0.3.x would (for a while) contain all patches without the youtube-dl dependency (so i migrated to that branch).

I might patch this package to use the upstream url but i am certain it would change a bit

EDIT: and you're right, the upstream url 404's indeed. I will fix that ASAP

eduruiz commented on 2019-02-27 15:20

I think this package is out of date but I'm not really sure, the upstream URL is giving me a 404. I needed the 0.5.4 version of the package (for use with tizonia-all) which I could upgrade only using pip2, it's really outdated or I'm missing something?

xiretza commented on 2019-01-12 12:36

makedepends=('git') - see https://wiki.archlinux.org/index.php/VCS_package_guidelines#Guidelines

joposter commented on 2016-02-15 10:17

@FlorianJacob since it provides python2-pafy i don't think it should conflict it... i do not know if pacman autoconflicts the providing packages or thinks that it is a reinstall. either way, it conflicts python-pafy because it shares /usr/bin/ytdl with it.

FlorianJacob commented on 2016-02-15 02:46

I think this should conflict with python2-pafy and not python-pafy - probably a typo?

joposter commented on 2015-08-26 00:18

python2-pafy-git will be impossible atm due to added youtube-dl dependency and missing python2-youtube-dl package (which i might add later).

for now, use python2-pafy, where this dependency does not exist yet ;)

EDIT: fixed now (yay) thanks to ids1024 (see changelog)

joposter commented on 2015-07-24 18:01

moved this from aur.archlinux.org
added me as maintainer for now :)