Package Details: python2-pandas-git 8848.7e2f7bc-1

Git Clone URL: https://aur.archlinux.org/python2-pandas-git.git (read-only)
Package Base: python2-pandas-git
Description: R-like data analysis library for Python.
Upstream URL: http://pandas.pydata.org
Licenses: BSD
Conflicts: python2-pandas
Provides: python2-pandas
Submitter: Foucault
Maintainer: Foucault
Last Packager: Foucault
Votes: 2
Popularity: 0.000000
First Submitted: 2013-10-14 17:01
Last Updated: 2015-06-13 11:51

Dependencies (18)

Required by (63)

Sources (1)

Latest Comments

Foucault commented on 2019-10-13 23:11

As it seems pandas is not compatible with python2 anymore. The last version supporting python2 is 0.24.2. The obvious solution to that is "use python 3". If you can't I've uploaded a package of the last version that supports python2

https://aur.archlinux.org/packages/python2-pandas

skaphle commented on 2019-10-13 19:58

If I try to install this package using yay, I get the error:

Traceback (most recent call last):
  File "setup.py", line 21, in <module>
    import versioneer
  File "/home/xxxx/.cache/yay/python2-pandas-git/src/pandas/versioneer.py", line 1629
    print("Adding sample versioneer config to setup.cfg", file=sys.stderr)
                                                              ^
SyntaxError: invalid syntax
==> ERROR: A failure occurred in build().
    Aborting...
Error making: python2-pandas-git

bcb commented on 2019-09-04 13:26

I'm not using Python 2 directly.

However, I am using python-boken (the Python 3 version of it). But since it is a split package, building it means building both python-bokeh and python2-bokeh. In turn, this requires python2-pandas as a make dependency. My AUR helper automatically uninstalls all these Python 2 packages after building.

In other words: I have no interest in maintaining a Python 2 package, but occasionally I need to build one, and the easiest way for me is to pin the version of this package.

Hopefully once Python 2 is dropped from the main repos at the end of the year, people will start having separate packages for python and python2 rather than using split packages, and these annoying workarounds can become a thing of the past...

Foucault commented on 2019-09-04 10:02

If that's the case is there really a need for -git package? It's just a regular package. In my opinion it would make more sense to remove this package and create a new python2-pandas with a fixed version at 0.24.2.

@bcb If you are using the python2 version it would make more sense to create the package as you are more likely to have it maintained properly.

bcb commented on 2019-08-21 07:10

As of the latest release Pandas does not support Python 2. If you still need this package (I do in a roundabout way as some AUR Python split packages depend on it for their Python 2 build) then edit the PKGBUILD to add #tag=v0.24.2 to the end of the Git URL in sources. This pins it to a version that still supports Python 2.

Foucault commented on 2014-02-23 10:13

Indeed. It is cython2 instead of cython. Thanks!

lothar_m commented on 2014-02-23 02:37

It seems that cython2 is required to build the package.