Package Details: python2-plotly 3.7.1-1

Git Clone URL: https://aur.archlinux.org/python-plotly.git (read-only)
Package Base: python-plotly
Description: An interactive, browser-based graphing library for Python2
Upstream URL: https://plot.ly/python/
Keywords: chart plot python
Licenses: MIT
Submitter: fclad
Maintainer: fclad (NicoHood)
Last Packager: NicoHood
Votes: 20
Popularity: 1.013282
First Submitted: 2015-12-07 14:53
Last Updated: 2019-03-30 16:45

Latest Comments

1 2 Next › Last »

oneup commented on 2019-04-18 15:46

python-plotly: Needs a dependency for python-decorator

python2-plotly: Needs dependencies for python2-decorator, python2-retrying

It looks like retrying is in plotly's requirements.txt, but you might need to also request upstream to add decorator to their dependencies too.

Traceback (most recent call last):
  File "plot_latency.py", line 5, in <module>
    from plotly.offline import plot
  File "/usr/lib/python3.7/site-packages/plotly/__init__.py", line 31, in <module>
    from plotly import (plotly, dashboard_objs, graph_objs, grid_objs, tools,
  File "/usr/lib/python3.7/site-packages/plotly/plotly/__init__.py", line 10, in <module>
    from . plotly import (
  File "/usr/lib/python3.7/site-packages/plotly/plotly/plotly.py", line 33, in <module>
    from plotly import exceptions, files, session, tools, utils
  File "/usr/lib/python3.7/site-packages/plotly/tools.py", line 18, in <module>
    from plotly import exceptions, optional_imports, session, utils
  File "/usr/lib/python3.7/site-packages/plotly/utils.py", line 22, in <module>
    from decorator import decorator
ModuleNotFoundError: No module named 'decorator'
Traceback (most recent call last):
  File "plot_latency.py", line 5, in <module>
    from plotly.offline import plot
  File "/usr/lib/python2.7/site-packages/plotly/__init__.py", line 31, in <module>
    from plotly import (plotly, dashboard_objs, graph_objs, grid_objs, tools,
  File "/usr/lib/python2.7/site-packages/plotly/plotly/__init__.py", line 10, in <module>
    from . plotly import (
  File "/usr/lib/python2.7/site-packages/plotly/plotly/plotly.py", line 34, in <module>
    from plotly.api import v1, v2
  File "/usr/lib/python2.7/site-packages/plotly/api/v1/__init__.py", line 3, in <module>
    from plotly.api.v1.clientresp import clientresp
  File "/usr/lib/python2.7/site-packages/plotly/api/v1/clientresp.py", line 9, in <module>
    from plotly.api.v1.utils import request
  File "/usr/lib/python2.7/site-packages/plotly/api/v1/utils.py", line 5, in <module>
    from retrying import retry
ImportError: No module named retrying

amdj commented on 2019-04-01 15:04

Since last update, I also get conflicting files errors, more or less simular to @markzz:

/usr/etc/jupyter/nbconfig/notebook.d/plotlywidget.json exists in both 'python2-plotly' and 'python-plotly'
/usr/share/jupyter/nbextensions/plotlywidget/extension.js exists in both 'python2-plotly' and 'python-plotly'
/usr/share/jupyter/nbextensions/plotlywidget/index.js exists in both 'python2-plotly' and 'python-plotly'

thewhoo commented on 2019-03-15 15:13

Thanks for the package, however, there are missing python-matplotlib dependencies. I've posted a patch here: https://pastebin.com/W7avn0hj

Tharbad commented on 2019-02-16 08:15

There are conflicting files errors. Same as @markzz got 4 months ago. :(

tycho commented on 2018-10-11 17:40

How about moving the conflicting files to a plotly-common package, and have both python2-plotly and python-plotly depend on that?

NicoHood commented on 2018-10-03 12:42

I am not sure why those files are in /usr/etc, but I am also not sure if moving them to /etc is correct. Any help appreciated.

About the other conflicts: I could make the packages conflict against each other, or delete them in the python2 package and make it depend on the python3 one. I am not sure if this is a good solution. Any ideas?

markzz commented on 2018-10-02 06:49

When built today and if you attempt to install both packages, you have some conflicts in /usr/share. Also, there's files in /usr/etc that should be in /etc.

/usr/etc/jupyter/nbconfig/notebook.d/plotlywidget.json exists in both 'python-plotly' and 'python2-plotly'
/usr/share/jupyter/nbextensions/plotlywidget/extension.js exists in both 'python-plotly' and 'python2-plotly'
/usr/share/jupyter/nbextensions/plotlywidget/index.js exists in both 'python-plotly' and 'python2-plotly'
/usr/share/jupyter/nbextensions/plotlywidget/index.js.map exists in both 'python-plotly' and 'python2-plotly'

roarchero commented on 2017-11-10 10:51

for updating to version 2.2.1:
I think its sufficient to change the pkgver to 2.2.1 and sha512sum to f72650eb62a9f095332fb10a3c849a8d789f674fa31e05fcb8961f22a4cd7b758cf2688494ff200878ccf3a9f7c298ca29abc8dc16dcec8ca514d536e499f16e in the PKGBUILD.
at least it seems like it is working then..

fclad commented on 2017-06-30 14:10

Done!

Thanks for your contributions NicoHood!

NicoHood commented on 2017-06-17 09:28

Please add the optional dependency "python-numpy: plotly tables"
https://plot.ly/python/table/

You can also add me as co-maintainer :)