Package Details: python2-poppler-qt4 0.24.0-2

Git Clone URL: https://aur.archlinux.org/python2-poppler-qt4.git (read-only)
Package Base: python2-poppler-qt4
Description: A Python 2 binding to poppler-qt
Upstream URL: https://github.com/wbsoft/python-poppler-qt4
Licenses: LGPL
Conflicts: python2-poppler-qt<=0.24.0
Submitter: lorenzph
Maintainer: XavierCLL
Last Packager: XavierCLL
Votes: 40
Popularity: 0.000000
First Submitted: 2015-05-25 13:14
Last Updated: 2017-01-24 14:40

Latest Comments

XavierCLL commented on 2017-01-24 14:41

Thanks for the advice jarylc, fixed!

jarylc commented on 2017-01-24 08:26

Seems to have a problem compiling on latest versions of python2-sip (4.19)

A GitHub user, zehome, forked the codes and provided a fix. Might be a good idea to use his fork instead for the sources

https://github.com/zehome/python-poppler-qt4

weilinear commented on 2016-03-20 14:21

@matrs "***Can't determine version of poppler-qt4 ***" seems that pkg-config does not work properly. Try to (re)install pkg-config?

matrs commented on 2016-03-02 21:55

Still (***almost***) the same error:

building 'popplerqt4' extension
***Can't determine version of poppler-qt4 ***
/usr/bin/sip -I /usr/share/sip -t POPPLER_V0_12_0 -c build/temp.linux-x86_64-2.7 -b build/temp.linux-x86_64-2.7/poppler-qt4.sbf -I /usr/share/sip/PyQt4 -x VendorID -t WS_X11 -t Qt_4_8_7 -x Py_v3 poppler-qt4.sip
creating build/temp.linux-x86_64-2.7/build
creating build/temp.linux-x86_64-2.7/build/temp.linux-x86_64-2.7
gcc -pthread -DNDEBUG -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/python2.7 -I/usr/include/python2.7 -I/usr/include/qt4 -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -c build/temp.linux-x86_64-2.7/sippopplerqt4cmodule.cpp -o build/temp.linux-x86_64-2.7/build/temp.linux-x86_64-2.7/sippopplerqt4cmodule.o
In file included from build/temp.linux-x86_64-2.7/sippopplerqt4cmodule.cpp:7:0:
poppler-qt4.sip:25:29: fatal error: qt4/poppler-qt4.h: No such file or directory
compilation terminated.
error: command 'gcc' failed with exit status 1
==> ERROR: A failure occurred in build().
Aborting...

XavierCLL commented on 2016-02-28 22:28

ok, but try with this, (last try):

export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/include:/usr/include/poppler
sudo ldconfig

and compile the package in the same console.

matrs commented on 2016-02-28 22:08

Still getting the same error.

I searched and this problem exists for other people but not too many to be fair. I think i'm gonna use other software (I was trying to install krop) so it isnt really important for me. Thanks for the help.

XavierCLL commented on 2016-02-28 21:55

looks good, without problems, try first reinstalling the poppler-qt4 and before compile the package run "sudo ldconfig"

matrs commented on 2016-02-28 21:47

sorry, i forgot about that,

$ locate poppler-qt4.h
/usr/include/poppler/qt4/poppler-qt4.h

pacman -Ql |grep poppler-qt4.h
poppler-qt4 /usr/include/poppler/qt4/poppler-qt4.h

XavierCLL commented on 2016-02-28 21:42

what do you show with this command?:
pacman -Ql |grep poppler-qt4.h

matrs commented on 2016-02-28 20:55

Yes, i have poppler-qt4 installed

$ pacman -Q poppler-qt4
poppler-qt4 0.41.0-1

All comments