Package Details: python2-postfix-policyd-spf 1.3.2-1

Git Clone URL: https://aur.archlinux.org/python2-postfix-policyd-spf.git (read-only)
Package Base: python2-postfix-policyd-spf
Description: Python2 Postfix Sender Policy Framework (SPF) filter
Upstream URL: http://www.openspf.org/Software
Licenses: Apache
Conflicts: python-postfix-policyd-spf
Submitter: fsa
Maintainer: gothmog.todi
Last Packager: gothmog.todi
Votes: 6
Popularity: 0.000576
First Submitted: 2010-10-28 12:51
Last Updated: 2015-09-06 06:52

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

smirky commented on 2015-09-04 06:58

Please update to 1.3.2

gothmog.todi commented on 2014-06-08 20:14

adopted and updated to 1.3.1

richli commented on 2014-06-07 03:20

I'm flagging this as out-of-date and orphaning it. I no longer use this package and have opted instead for the Python 3 version.

richli commented on 2014-01-17 00:09

Another update, the "ipaddr" module in community [1] works better.

[1] https://www.archlinux.org/packages/community/any/python2-ipaddr/

richli commented on 2014-01-16 23:10

I've updated the package. The code depends on the "ipaddress" module introduced in Python 3.3. This has been backported to Python 2.6 and 2.7 and is available in the AUR here [1].

[1] https://aur.archlinux.org/packages/python2-ipaddress/

richli commented on 2014-01-16 22:08

I've adopted this package and updated it to the current version (1.2). I also recommend checking out the Python 3 version [1] if you have no need of a Python 2 version.

[1] https://aur.archlinux.org/packages/python-postfix-policyd-spf/

richli commented on 2013-06-30 01:43

This package has been out of date for over a year, is the maintainer not willing to update it?

gothmog.todi commented on 2013-06-08 10:03

https://aur.archlinux.org/packages/python2-authres/ is needed if you use "Header_Type = AR"

richli commented on 2013-05-25 22:04

And here's a unified diff to update the PKGBUILD to 1.1.2:

--- PKGBUILD.org 2012-10-27 09:55:28.000000000 -0700
+++ PKGBUILD 2013-05-25 15:00:20.814801006 -0700
@@ -2,7 +2,7 @@
# Contributor: Samed Beyribey <ras0ir@eventualis.org>
pkgname=python2-postfix-policyd-spf
_pkgname=pypolicyd-spf
-pkgver=0.8.1
+pkgver=1.1.2
pkgrel=1
pkgdesc="Python2 Postfix Sender Policy Framework (SPF) filter"
arch=('any')
@@ -11,13 +11,16 @@
depends=('postfix' 'python2-pyspf' 'python2')
conflicts=('python-postfix-policyd-spf')
options=(!emptydirs)
-source=(http://launchpad.net/pypolicyd-spf/0.8/$pkgver/+download/$_pkgname-$pkgver.tar.gz)
-md5sums=('a37c209e88e4dc419f62ae7c6b52f0e7')
+source=(http://launchpad.net/pypolicyd-spf/1.1/$pkgver/+download/$_pkgname-$pkgver.tar.gz)
+md5sums=('f876701a8733a2db2fca424d98581c7b')

build() {
cd "$srcdir/$_pkgname-$pkgver"
-
python2 setup.py build || return 1
+}
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
python2 setup.py install --root=$pkgdir/ --optimize=1 || return 1
install -m644 policyd-spf.conf.commented $pkgdir/etc/python-policyd-spf || return 1
}

Anonymous comment on 2012-04-07 03:01

Here is a unified diff of the PKGBUILD to update to 1.0

--- PKGBUILD.org 1970-01-01 10:13:08.000000000 +0100
+++ PKGBUILD 2012-04-07 04:53:11.642108953 +0200
@@ -1,7 +1,7 @@
# Contributor: Samed Beyribey <ras0ir@eventualis.org>
pkgname=python-postfix-policyd-spf
_pkgname=pypolicyd-spf
-pkgver=0.8.0
+pkgver=1.0
pkgrel=1
pkgdesc="Postfix SPF filter"
arch=('i686' 'x86_64')
@@ -9,7 +9,8 @@
license=('GPL')
depends=('postfix' 'python-pyspf')
makedepends=('python')
-source=(http://launchpad.net/pypolicyd-spf/0.8/$pkgver/+download/$_pkgname-$pkgver.tar.gz)
+source=("http://launchpad.net/pypolicyd-spf/$pkgver/$pkgver/+download/$_pkgname-$pkgver.tar.gz")
+md5sums=('67024c9c2912ed9a8acd43c429d2e4d6')

build() {
cd "$srcdir/$_pkgname-$pkgver"
@@ -21,4 +22,3 @@
python setup.py install --root=$pkgdir
install -m644 policyd-spf.conf.commented $pkgdir/etc/python-policyd-spf
}
-md5sums=('e562394356091fb4d0f142b7e8611305')

All comments