Package Details: python2-pwntools-git 3.13.0beta0.r51.gc89bed25-2

Git Clone URL: https://aur.archlinux.org/python2-pwntools-git.git (read-only)
Package Base: python2-pwntools-git
Description: A CTF framework and exploit development library. (git version, branch dev)
Upstream URL: https://github.com/Gallopsled/pwntools
Keywords: binary capture ctf defcon exploit flag heap overflow pwntools stack the wargame
Licenses: GPL2, BSD, MIT
Conflicts: python2-pwntools
Provides: python2-pwntools
Submitter: jerry73204
Maintainer: xtrm0
Last Packager: xtrm0
Votes: 2
Popularity: 0.001346
First Submitted: 2015-09-05 15:21
Last Updated: 2018-09-18 22:37

Latest Comments

mcd1992 commented on 2018-06-01 14:05

Currently broken but doesn't seem to be this packages fault. The ropgadget dependency now supports python3 and defaults to building py3 only with no py2 support.

modernrio commented on 2017-07-08 16:26

python2-sortedcontainers is a dependency I had to install manually to be able to use the framework.

jerry73204 commented on 2017-03-10 12:13

skogler: Nice idea. The package is now updated.

skogler commented on 2017-03-08 21:12

Could you add

--only-use-pwn-command

to the setup.py? Then you can remove the manual rename loop that is broken with current versions of pwntools.

Also, python2-intervaltree is a required dependency now, apparently.