Package Details: python2-pyftpdlib 1.5.1-1

Git Clone URL: (read-only)
Package Base: python2-pyftpdlib
Description: Complete asynchronous FTP server library in Python
Upstream URL:
Licenses: MIT
Conflicts: pyftpdlib
Submitter: sleduc
Maintainer: sleduc
Last Packager: sleduc
Votes: 8
Popularity: 0.008272
First Submitted: 2013-05-08 08:27
Last Updated: 2016-05-08 08:40

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

sleduc commented on 2013-07-15 17:08

Added as optdepend, thanks for your message.

darnir commented on 2013-07-14 22:26

python2-pyopenssl should be a dependency, or atleast an optdepends to python2-pyftpdlib since it relies only on the pyopenssl module for SSL connections.

sleduc commented on 2013-05-17 17:38

Fixed, thanks for your comment.

sl1pkn07 commented on 2013-05-08 20:26


change cd "$srcdir/$pkgname-$pkgver" to cd "$srcdir/pyftpdlib-$pkgver" in build()

and add

conflicts=('pyftpdlib') to replace the old package


sl1pkn07 commented on 2013-05-08 20:24


change cd "$srcdir/$pkgname-$pkgver" to cd "$srcdir/pyftpdlib-$pkgver" in build()


sleduc commented on 2013-05-08 08:37


I have created the package python2-pyftpdlib and sent a merge request to aur-general :)
Thanks for the notification.

sl1pkn07 commented on 2013-05-07 14:16

please, if is possible, rename the package to python2-pyftpdlib. because this library can build with python3 (python-pyftpdlib)


Anonymous comment on 2011-05-09 11:30

@eazy: Please exchange 'python' with 'python2' in the line where you call in the PKGBUILD.

Anonymous comment on 2010-10-22 10:25

The package no longer compiles after recent python updates, i.e. python 3.1 cannot build it.