Package Details: python2-pysvn 1.8.0-1

Git Clone URL: https://aur.archlinux.org/python2-pysvn.git (read-only)
Package Base: python2-pysvn
Description: Python2 SVN Extension.
Upstream URL: http://pysvn.tigris.org
Licenses: Apache
Conflicts: pysvn<=1.7.4-3, pysvn-py2
Provides: pysvn-py2
Replaces: pysvn-py2
Submitter: Zeph
Maintainer: Zeph
Last Packager: Zeph
Votes: 96
Popularity: 0.835740
First Submitted: 2013-01-02 20:35
Last Updated: 2016-03-06 11:05

Latest Comments

Zeph commented on 2015-09-04 18:48

Add patch for svn 1.9 => Build OK,

shkumbini commented on 2015-09-03 19:40

Anyone has any idea how to compile this package, it always shows errors.

utsi commented on 2015-08-20 08:35

Package is broken due to changes in public headers in libsvn. For 1.7.10 you need to rollback packages if you still wish to compile this.

warddr commented on 2012-12-27 02:06

I just tested this on "armv6h" (raspberry pi), and it works fine. Although it isn't in the list of supported architectures. Maybe this can be added?

Zeph commented on 2012-02-13 21:27

Remove subversion restriction version and compile for 1.7
In your svn project use "svn upgrade" for use subversion 1.7 and for rabbitvcs work

Zeph commented on 2012-02-13 21:20

For Remove subversion restriction version and compile for 1.7, change PKGBUILD,
in your svn project use "svn upgrade" for use subversion 1.7 and rabbitvcs work

PKGBUILD :
=========

# Contributor: Edvinas Valatka <edacval@gmail.com>
# Maintainer: Edvinas Valatka <edacval@gmail.com>

pkgname=pysvn-py2
pkgver=1.7.5
pkgrel=3
pkgdesc="Python2 SVN Extension."
url="http://pysvn.tigris.org"

##################################################################
# => Remove subversion restriction version !!!
depends=('python2>=2.7' 'subversion' 'apr' 'expat' 'neon' 'openssl')

conflicts=('pysvn<=1.7.4-3')
arch=('i686' 'x86_64')
license=('APACHE')
source=("http://pysvn.barrys-emacs.org/source_kits/pysvn-$pkgver.tar.gz")
md5sums=('3334718248ec667b17d333aac73d5680')
build() {
_pyver=`python2 -V 2>&1|sed -e 's/.* 2\.\([0-9]\).*/\1/'`
cd $srcdir/pysvn-$pkgver/Source

##################################################################
# => Include svn_version.h in top of file pysvn_svnenv.hpp !!
echo '#include <svn_version.h>' > pysvn_svnenv.new
cat pysvn_svnenv.hpp >> pysvn_svnenv.new
rm pysvn_svnenv.hpp
mv pysvn_svnenv.new pysvn_svnenv.hpp
##################################################################

python2 setup.py backport || return 1
python2 setup.py configure || return 1
make || return 1
install -D -m644 pysvn/__init__.py $pkgdir/usr/lib/python2.${_pyver}/site-packages/pysvn/__init__.py
install -D -m755 pysvn/_pysvn_2_${_pyver}.so $pkgdir/usr/lib/python2.${_pyver}/site-packages/pysvn/_pysvn_2_${_pyver}.so
}

Zeph commented on 2012-02-13 21:18

For Remove subversion restriction version and compile for 1.7, change PKGBUILD,
in your svn project use "svn upgrade" for use subversion 1.7 and rabbitvcs work

PKGBUILD :
=========

# Contributor: Edvinas Valatka <edacval@gmail.com>
# Maintainer: Edvinas Valatka <edacval@gmail.com>

pkgname=pysvn-py2
pkgver=1.7.5
pkgrel=3
pkgdesc="Python2 SVN Extension."
url="http://pysvn.tigris.org"

##################################################################
# => Remove subversion restriction version !!!
depends=('python2>=2.7' 'subversion' 'apr' 'expat' 'neon' 'openssl')

conflicts=('pysvn<=1.7.4-3')
arch=('i686' 'x86_64')
license=('APACHE')
source=("http://pysvn.barrys-emacs.org/source_kits/pysvn-$pkgver.tar.gz")
md5sums=('3334718248ec667b17d333aac73d5680')
build() {
_pyver=`python2 -V 2>&1|sed -e 's/.* 2\.\([0-9]\).*/\1/'`
cd $srcdir/pysvn-$pkgver/Source

##################################################################
# => Include svn_version.h in top of file pysvn_svnenv.hpp !!
echo '#include <svn_version.h>' > pysvn_svnenv.new
cat pysvn_svnenv.hpp >> pysvn_svnenv.new
rm pysvn_svnenv.hpp
mv pysvn_svnenv.new pysvn_svnenv.hpp
##################################################################

python2 setup.py backport || return 1
python2 setup.py configure || return 1
make || return 1
install -D -m644 pysvn/__init__.py $pkgdir/usr/lib/python2.${_pyver}/site-packages/pysvn/__init__.py
install -D -m755 pysvn/_pysvn_2_${_pyver}.so $pkgdir/usr/lib/python2.${_pyver}/site-packages/pysvn/_pysvn_2_${_pyver}.so
}

edacval commented on 2011-12-27 00:16

Temporary workaround until compatibility with subversion > 1.7 will be fixed in upstream : install subversion-1.6 ( https://aur.archlinux.org/packages.php?ID=55172 )

edacval commented on 2011-12-27 00:10

http://pysvn.tigris.org/project_status.html

dluciv commented on 2011-12-26 22:05

subversion<1.7 dependency is now preventing this package from install/upgrade.

I personally do not know if subversion bacame incompatible after 1.7 or if there is any other reason beyound this restriction...

All comments