Package Details: python2-pytz 2024.1-1

Git Clone URL: https://aur.archlinux.org/python2-pytz.git (read-only, click to copy)
Package Base: python2-pytz
Description: Cross platform time zone library for Python2
Upstream URL: https://pypi.python.org/pypi/pytz
Licenses: MIT
Submitter: micwoj92
Maintainer: LaughingMan
Last Packager: micwoj92
Votes: 2
Popularity: 0.000163
First Submitted: 2021-11-13 11:54 (UTC)
Last Updated: 2024-02-03 06:46 (UTC)

Latest Comments

micwoj92 commented on 2023-12-18 23:10 (UTC)

Any more requests? I will do the change later today.

MarsSeed commented on 2023-12-18 20:46 (UTC) (edited on 2023-12-18 20:50 (UTC) by MarsSeed)

Please make this package use system timezone info from the tzdata package, just like repo's python-pytz does.

Otherwise there will be some discrepancies between the timezone info used by the Arch system and Python2 applications.

micwoj92 commented on 2023-07-05 19:44 (UTC)

About depends, I still don't really think these are needed. Tests are also working without pytest (I don't even know what different pytest would make here). Also normal python-pytz package doesn't have these, if this will be added to py3 package then I will add this here.

I will add skip build option on next package version bump.

MarsSeed commented on 2023-07-05 16:43 (UTC)

Also, please add --skip-build to the CLI options of python2 setup.py install, to avoid building a second time.

MarsSeed commented on 2023-07-05 16:39 (UTC) (edited on 2023-07-05 16:41 (UTC) by MarsSeed)

Upstream defines setuptools as make dependency, and pytest as testing dependency.

Also, even Python 2.7 packaging documentation recommends against using distutils directly in favor of setuptools, "for more consistent behavior".

Arch wiki's Python package guidelines say:

Some packages try to use setuptools and fall back to distutils if setuptools could not be imported. In this case, setuptools should be added as a makedepends, so that the resulting Python metadata is better.

micwoj92 commented on 2023-07-05 16:06 (UTC)

Is this really needed? It seems to do just fine using built-in distutils.

MarsSeed commented on 2023-07-05 15:22 (UTC)

Please add python2-setuptools to makedepends.