Package Details: python2-pywikibot-git 1:3.0.20200111.r0.gb9203461-1

Git Clone URL: https://aur.archlinux.org/python2-pywikibot-git.git (read-only, click to copy)
Package Base: python2-pywikibot-git
Description: Python library that interfaces with the MediaWiki API
Upstream URL: https://www.mediawiki.org/wiki/Manual:Pywikibot
Keywords: API bot framework mediawiki pwb python pywikibot pywikipedia pywikipediabot wiki wikimedia wikipedia
Licenses: MIT
Conflicts: python2-pywikibot
Provides: python2-pywikibot
Submitter: yar
Maintainer: dvorapa
Last Packager: dvorapa
Votes: 6
Popularity: 0.000000
First Submitted: 2013-10-10 01:39
Last Updated: 2020-01-11 19:18

Latest Comments

aleskva commented on 2019-06-30 23:11

@GrantWilson There are several good Python tools for structured data. I know at least about Daty, DBpedia, Pywikibot and WikidataIntegrator.

GrantWilson commented on 2019-05-27 08:22

In case you need to extract structured data from Wikipedia, there's a good tool DbPedia used by pro experts. They also suggest examples of using SPARQL libraries on https://stackoverflow.com/questions/627594/is-there-a-wikipedia-api and https://hireessaywriter.org/write-me-an-essay.html case studies on MediaWiki API wrapper.

Gallaecio commented on 2014-04-03 13:53

I get:

==> Starting package()...
running install
Checking .pth file support in /home/achaves/aqueronte/python2-pywikibot-git/python2-pywikibot-git/pkg/python2-pywikibot-git/usr/lib/python2.7/site-packages/
/usr/bin/python2 -E -c pass
TEST FAILED: /home/achaves/aqueronte/python2-pywikibot-git/python2-pywikibot-git/pkg/python2-pywikibot-git/usr/lib/python2.7/site-packages/ does NOT support .pth files
error: bad install directory or PYTHONPATH

You are attempting to install a package to a directory that is not
on PYTHONPATH and which Python does not read ".pth" files from. The
installation directory you specified (via --install-dir, --prefix, or
the distutils default setting) was:

/home/achaves/aqueronte/python2-pywikibot-git/python2-pywikibot-git/pkg/python2-pywikibot-git/usr/lib/python2.7/site-packages/

and your PYTHONPATH environment variable currently contains:

''

jleclanche commented on 2013-12-15 01:37

Not building here: http://dpaste.com/1505722/

jleclanche commented on 2013-12-15 01:37

Not building here:

legoktm commented on 2013-10-10 21:24

git.wikimedia.org is pretty slow, I recommend you use the Gerrit url directly: https://gerrit.wikimedia.org/r/p/pywikibot/core.git

yar commented on 2013-10-10 19:59

Also note that upstream does some very bad-practice things in its directory structure and config process. Filed bugs with them:

https://bugzilla.wikimedia.org/show_bug.cgi?id=55583
https://bugzilla.wikimedia.org/show_bug.cgi?id=55584

yar commented on 2013-10-10 18:54

Thanks for your work on this, but upstream moved to git a while back. I made a new package based on yours: https://aur.archlinux.org/packages/python2-pywikibot-git/

yar commented on 2013-10-10 18:52

This PKGBUILD borrows heavily from python2-wikipedia-rewrite-svn. I'll be maintaining it at: https://github.com/yardenac/pkgbuilds/tree/master/packages/python2-pywikibot-git

Please note that git.mediawiki.org is flaky and gives http hangups about half the time. Try running makepkg a few times before reporting a bug.