Package Details: python2-qtpy-git 0.1.2.r24.gd336f1b-2

Git Clone URL: https://aur.archlinux.org/python-qtpy-git.git (read-only)
Package Base: python-qtpy-git
Description: Provides a uniform layer to support PyQt4, PyQt5 and PySide with a single codebase
Upstream URL: https://github.com/spyder-ide/qtpy
Licenses: MIT
Conflicts: python2-qtpy
Provides: python2-qtpy
Submitter: willemw
Maintainer: willemw
Last Packager: willemw
Votes: 7
Popularity: 0.000020
First Submitted: 2015-12-05 17:52
Last Updated: 2015-12-06 12:58

Dependencies (6)

Required by (1)

Sources (1)

Latest Comments

willemw commented on 2016-06-18 06:20

These are the latest versions I see:
python2-qtpy-git-1.0.2.r71.g69f16d3-1
spyder3: setup.py: 'qtpy>=1.0.2',

JohnRobson commented on 2016-06-17 19:17

VERSION ERROR: I installed "python-qtpy-git 0.1.2.r24.gd336f1b-2", but:

$ pip search qtpy
QtPy (1.0b1) - Provides an abstraction layer on top of the various Qt bindings (PyQt5, PyQt4 and PySide) and additional custom QWidgets.
INSTALLED: 1.1.0.dev0
LATEST: 1.0b1

spyder3-git check for >= 1.2

JohnRobson commented on 2016-06-17 19:17

VERSION ERROR: I installed "python-qtpy-git 0.1.2.r24.gd336f1b-2", but:

$ pip search qtpy
QtPy (1.0b1) - Provides an abstraction layer on top of the various Qt bindings (PyQt5, PyQt4 and PySide) and additional custom QWidgets.
INSTALLED: 1.1.0.dev0
LATEST: 1.0b1

spyder3-git check for >= 1.2

willemw commented on 2015-12-06 13:01

@Nabobalis: Thanks. Fixed 'provides' and 'conflicts' of python2-qtpy-git and python2-qtawesome-git.

Nabobalis commented on 2015-12-06 11:08

Should this not provide python2-qtpy, since this conflicts with the Python 3 version?