Package Details: python2-shiboken2 5.12.1-1

Git Clone URL: https://aur.archlinux.org/python2-shiboken2.git (read-only)
Package Base: python2-shiboken2
Description: Generates bindings for C++ libraries using CPython source code
Upstream URL: http://qt-project.org/
Licenses: GPL2, LGPL
Submitter: gbs
Maintainer: gbs
Last Packager: gbs
Votes: 31
Popularity: 1.610130
First Submitted: 2018-06-28 18:32
Last Updated: 2019-02-06 21:51

Latest Comments

jefbed commented on 2019-01-25 18:19

Now it works, saying that it is extracting with bsdtar as expected. I'd write this off as a quirk with my system or some external/kernel race condition of sorts that I stumbled upon momentarily. extract_file switches amongst the specific archivers, then defaults to bsdtar, as expected. I'm curious if this is a hardware issue, though I don't see any errant dmesg output.

gbs commented on 2019-01-25 17:19

jefbed: what makepkg says in the Extracting sources... section? Should be Extracting pyside-setup-everywhere-src-5.12.0.tar.xz with bsdtar. Also, can you check the file /usr/share/makepkg/source/file.sh? More specifically, what do you have in the extract_file() function?

jefbed commented on 2019-01-25 16:43

I just reinstalled libarchive, reverted my PKGBUILD change, and performed 'makepkg -f', resulting in the same error. The outer archive is getting uncompressed but not untarred. I added a conditional and generated the following patch. I'm continuing to research potential local problems, but this only seems to be happening on python2-shiboken2 and python2-pyside2.

gbs commented on 2019-01-25 09:24

jefbed: This makes no sense. Compressed sources are extracted automatically by libarchive, which is a dependency of pacman. Can you check your system for corruption?

jefbed commented on 2019-01-25 06:48

This package fails to build for me. In order to get it to build, I had to add the following to the beginning of build(): tar xf pyside-setup-everywhere-src-5.12.0.tar

Delan commented on 2019-01-01 17:14

Thank you gbs, I worked for me. I had to wait for the Manjaro update ;)

gbs commented on 2018-12-30 21:59

Rider_ranger47, Delan: you both need to update your systems before installing new software. You apparently still have an old version of Qt which doesn't have that method. I've added an explicit version dependency to prevent this happening again.

Delan commented on 2018-12-28 10:38

Same problem as the one of Rider_ranger47 (https://www.dropbox.com/s/up2jsy537w2pjy6/python2-shiboken2%205.12.0-1.txt?dl=0). Obviously blocks the install of dependant software (freecad in my case).

I tried to delete the existing build files in /var/tmp/pamac-build-<user>/python2-shiboken2/ to force the re-download of potentially corrupted files but install still fails.

Rider_ranger47 commented on 2018-12-23 19:39

Hi, this package fails to build for me with the following very long errors: https://p.teknik.io/4wac2