Package Details: python2-sipsimple 3.1.1-1

Git Clone URL: (read-only)
Package Base: python2-sipsimple
Description: Python SDK for development of SIP end-points
Upstream URL:
Keywords: SIP
Licenses: LGPL, custom:MIT
Submitter: promike
Maintainer: ogarcia
Last Packager: ogarcia
Votes: 7
Popularity: 0.376028
First Submitted: 2016-06-01 14:02
Last Updated: 2017-05-10 07:33

Latest Comments

theforeigner commented on 2017-05-29 09:32

Hah! Finally found what was causing my problems with building and running sipsimple and blink!

I'm using ffmpeg-nvenc-full, a custom ffmpeg build. Everyone using something else but the standard ffmpeg package will most likely get the same errors. Even though blink uses ffmpeg2.8 and not 3.1+, this is what's causing it.

The workaround is simple:
1) Replace ffmpeg: pacman -S ffmpeg (choose yes to replace the current ffmpeg package)
2) Remove openh264: pacman -R openh264 (and possibly other packages installed by your custombuilt ffmpeg package that aren't installed by the default ffmpeg package)
3) Install blink: pacman -S blink
4) Re-replace the default ffmpeg with your custom ffmpeg build: pacman -S ffmpeg-full/ffmpeg-full-nvenc/whatever

theforeigner commented on 2017-05-20 09:44

Meh.. I kept getting the ol' openh264 error. Doing the workaround suggested by @eskimod and removing the openh264 package instead produces this error:

error: PJSIP TLS support was disabled, OpenSSL development files probably not present on this system

The OpenSSL workaround doesn't work for me either. I tried using openssl-1.0-compat and as well, and also recompiled the latest python2-eventlib 0.2.3 from git that supposedly fixed OpenSSL 1.1+ compatibility. But that didn't change anything.

ogarcia commented on 2017-05-10 07:09

@ngld Updated! Many thanks!

ngld commented on 2017-05-09 22:53

Apparently this package isn't compatible with openssl 1.1.0.
It simply aborts with "error: PJSIP TLS support was disabled, OpenSSL development files probably not present on this system".

Here's a changed the PKGBUILD which compiles against openssl-1.0:

The new PKGBUILD fixed the problem for me.

ogarcia commented on 2017-03-01 10:23


Many thanks!!!

promike commented on 2017-03-01 10:22


Good luck with it :)

ogarcia commented on 2017-03-01 09:22

Package updated!

As I can see, seems that AG Projects are maintaining the packages in GitHub and not in their own "devel".

This not is a -git version cause not are based in master. Is using a tagged release ;).

promike commented on 2017-02-11 09:35


I wish I could have been more help.
Anyway, according to the sipsimple is still up-to-date.

If you have problems with your Blink;
a) you can try compiling Blink 2.0 from here:

b) you can try ogarcia's version of sipsimple. Somewhere around here:

I purged Blink from my machine, so I don't know which works the best :/

theforeigner commented on 2017-02-11 04:29

I noticed it as well, that AG Projects has a very messy repository and different versions in different locations. I've taken on to studying and understanding the Arch Build System, maybe one day I'll feel frisky enough to take on and maintain some package myself. Thanks for the great work you've done!

promike commented on 2017-01-30 17:28

I'm not going to maintain this package any more. It cannot be followed!
There are so many sources and this can't suit to every single version, e.g. Ogarcia's package which uses a completely different source, whereas I stuck with the stable one
(But there is a third source just to see it's not that easy: )
If you visit the site: you can see that sipsimple is up-to-date and this package was not supposed to be -git version.
I don't think it's a good idea to mix them, so I decided not to struggle with this.

Sooo, long story short. This package and it's dependencies can be adopted.

All comments