Package Details: python2-spake2 0.8-4

Git Clone URL: https://aur.archlinux.org/python-spake2.git (read-only)
Package Base: python-spake2
Description: This library implements the SPAKE2 password-authenticated key exchange
Upstream URL: https://pypi.python.org/packages/10/7d/spake2-0.8
Licenses: MIT
Submitter: stormdragon2976
Maintainer: stormdragon2976
Last Packager: stormdragon2976
Votes: 5
Popularity: 0.117873
First Submitted: 2016-08-10 00:53
Last Updated: 2018-11-03 18:18

Latest Comments

stormdragon2976 commented on 2018-03-02 10:46

@lswest, I did this both of the previous times I updated the package. I ran makepkg -g and placed the new md5sum in the PKGBUILD. I did it again just now, and it gave me a different md5sum. This time it seems to work. I'm not sure what was going on there. All's well that ends well though I guess. :)

lswest commented on 2018-03-02 08:37

@stormdragon2976 the build was failing because the MD5SUM wasn't correct. After deleting it and running makepkg -g >> PKGBUILD it was built successfully. It also seems like the source contained the files for 0.8. I haven't actually tested that magic-wormhole is working, but it seems to have solved the issue.

stormdragon2976 commented on 2018-03-02 02:07

@ruahcra, I have changed the version back to 0.8. It is failing to build now, from what I can tell, it downloads the correct version.tar.gz, but when extracted, it contains 0.7 instead. I'm not sure if it is something I am doing wrong, or an oversight in the package itself. However, pip install does load the correct version.

ruahcra commented on 2018-03-01 13:48

I believe the PKGBUILD is wrong - it's building from 0.7 instead of 0.8. magic-wormhole is broken because of this as it depends on spake2==0.8.