Package Details: python2-telepot-git r389.aad059b-1

Git Clone URL: https://aur.archlinux.org/python-telepot-git.git (read-only)
Package Base: python-telepot-git
Description: telepot protocol implementation for Python
Upstream URL: https://github.com/nickoala/telepot
Licenses: MIT
Submitter: zaycakitayca
Maintainer: zaycakitayca
Last Packager: zaycakitayca
Votes: 0
Popularity: 0.000000
First Submitted: 2017-03-30 18:37
Last Updated: 2017-03-30 18:37

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

Cbhihe commented on 2018-06-26 11:30

Hi I am getting an unresolved dependency conflict between python2-telepot-git and python-telepot-git.

Output's tail is as follow (nothing remarkable before):

[...] Copying telepot.egg-info to /var/builds/python-telepot-git/pkg/python2-telepot-git/usr/lib/python2.7/site-packages/telepot-12.7-py2.7.egg-info <br> running install_scripts ==> Tidying install... -> Removing libtool files... -> Purging unwanted files... -> Removing static library files... -> Stripping unneeded symbols from binaries and libraries... -> Compressing man and info pages... ==> Checking for packaging issues... ==> Creating package "python2-telepot-git"... -> Generating .PKGINFO file... -> Generating .BUILDINFO file... -> Generating .MTREE file... -> Compressing package... ==> Leaving fakeroot environment. ==> Finished making: python-telepot-git r430.3792fde-1 (Tue 26 Jun 2018 13:16:42 CEST) <br> ==> Installing python-telepot-git package group with pacman -U... loading packages... resolving dependencies... looking for conflicting packages... error: unresolvable package conflicts detected error: failed to prepare transaction (conflicting dependencies) :: python-telepot-git and python2-telepot-git are in conflict ==> WARNING: Failed to install built package(s). ==> Cleaning up...

I looked at PKGBUILD and nothing there struck me as being out of the ordinary.

Am doing something very wrong, here ?

Binabik commented on 2017-10-24 09:35

It seems to me that python-telepot depends on python-urllib3. Maybe, this has to be added as a dependency?