Package Details: python2-whois 0.7.3-1

Git Clone URL: https://aur.archlinux.org/python-whois.git (read-only, click to copy)
Package Base: python-whois
Description: Whois querying and parsing of domain registration information
Upstream URL: https://bitbucket.org/richardpenman/pywhois
Licenses: custom
Submitter: sanerb
Maintainer: sanerb
Last Packager: sanerb
Votes: 2
Popularity: 0.000616
First Submitted: 2017-10-07 15:30 (UTC)
Last Updated: 2020-10-07 17:01 (UTC)

Pinned Comments

sanerb commented on 2020-10-07 16:37 (UTC)

Please note the following additions:

Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
News updates for packages can be followed at https://devblog.square-r00t.net

(If you want an RSS-feed only pertaining to my AUR packages, you can subscribe to https://devblog.square-r00t.net/rss/?category=aur in your favourite RSS reader.)

Note that you should still use the AUR web interface for flagging packages as out-of-date if a new version is released; the aforementioned bug tracker is to aid in issues with building/packaging/the PKGBUILD formats/etc. specifically.

GPG signature "errors" are explained here: https://devblog.square-r00t.net/articles/a-note-on-using-gpg-signatures-in-pkgbuilds

Please read; it's not a bug.

Thanks!

Latest Comments

yochananmarqos commented on 2022-01-14 16:00 (UTC)

Upstream URL is now https://github.com/richardpenman/whois.

reclusivesage commented on 2021-12-15 19:29 (UTC)

Is this warning supposed to happen? I have to answer "Yes":

warning: cannot resolve "python2-futures", a dependency of "python2-whois"
:: The following package cannot be upgraded due to unresolvable dependencies:
      python2-whois

:: Do you want to skip the above package for this upgrade? [y/N] Y
looking for conflicting packages...

in order to proceed normally, or else the install stops:

:: Do you want to skip the above package for this upgrade? [y/N] n
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency 'python2-futures' required by python2-whois
==> WARNING: Failed to install built package(s)

sanerb commented on 2020-10-07 16:37 (UTC)

Please note the following additions:

Bug reports can be filed at https://bugs.square-r00t.net/index.php?project=3
News updates for packages can be followed at https://devblog.square-r00t.net

(If you want an RSS-feed only pertaining to my AUR packages, you can subscribe to https://devblog.square-r00t.net/rss/?category=aur in your favourite RSS reader.)

Note that you should still use the AUR web interface for flagging packages as out-of-date if a new version is released; the aforementioned bug tracker is to aid in issues with building/packaging/the PKGBUILD formats/etc. specifically.

GPG signature "errors" are explained here: https://devblog.square-r00t.net/articles/a-note-on-using-gpg-signatures-in-pkgbuilds

Please read; it's not a bug.

Thanks!

yochananmarqos commented on 2020-09-30 04:53 (UTC)

Updated PKGBUILD

khalil2535 commented on 2020-09-09 11:58 (UTC) (edited on 2020-09-09 11:59 (UTC) by khalil2535)

got this error


==> Verifying source file signatures with gpg...
    python-whois-0.7.1.tar.gz ... FAILED (unknown public key 8C004C2F93481F6B)
    LICENSE ... FAILED (unknown public key 8C004C2F93481F6B)
==> ERROR: One or more PGP signatures could not be verified!
error downloading sources: python-whois