Package Details: python2-wtforms 2.1-1

Git Clone URL: https://aur.archlinux.org/python2-wtforms.git (read-only)
Package Base: python2-wtforms
Description: A flexible forms validation and rendering library for python web development.
Upstream URL: http://pypi.python.org/pypi/WTForms
Licenses: BSD
Submitter: mitsuse
Maintainer: notizblock
Last Packager: notizblock
Votes: 13
Popularity: 0.056191
First Submitted: 2012-05-21 14:44
Last Updated: 2015-12-22 18:16

Latest Comments

lpapp commented on 2013-08-13 09:21

Hi, may I ask you and a TU to switch this package to community?

I think it is essential for any work related to flask as forms are pretty common.

foutrelis commented on 2012-07-23 10:51

Merged into python2-wtforms: https://aur.archlinux.org/packages.php?ID=59420

fxkr commented on 2012-05-22 17:30

Wow, that was fast :) Thanks!

mitsuse commented on 2012-05-22 16:41

Oh!! I'm sorry I was so careless.
Fixed. Thank you!!

fxkr commented on 2012-05-22 16:07

Broken:

- You're using "python" instead of "python2"
- Quote all variables. This is important!
- Don't list unzip in makedeps. BTW, the field is called "makedepends"
- Add --optimize=1 to the "python2 setup.py install" line

I suggest you have a look at /usr/share/pacman/PKGBUILD-python.proto

Anonymous comment on 2012-05-19 07:25

I'm not sure I'll be able to maintain this package in the long term, so I won't adopt it; I have subscribed to its notices and I'll try to keep in shape until you'll be able to take care of it.

fxkr commented on 2012-05-18 13:38

valhalla: thanks for taking care of it! Feel free to adopt it permanently.

(I'm kind of *really* busy right now and have been for the past three months. If it's still orphaned in a month or so when my schedule finally clears up I may pick it up again. Till then I'd just be in the way.)

Anonymous comment on 2012-05-17 07:10

I have noticed this was still orphan and out of date, so I've uploaded an updated version and reorphaned.

Is anybody (fxkr?) still interested in adopting the package?

fxkr commented on 2011-01-23 00:29

I had a TU orphan the package for me and have adopted and updated it now.

FSX commented on 2011-01-22 22:46

I emailed the guy about it a while ago, but he didn't disown it.

fxkr commented on 2011-01-22 22:19

PS: While just changing python to python2 might work, the version number in the PKGBUILD should also be updated. Current version is 0.6.2, released today. But then the PKGBUILD hasnt been updated for over a year now...

fxkr commented on 2011-01-22 22:14

welterde, could you please update the PKGBUILD or disown it?

whitelynx commented on 2011-01-12 23:01

I get an error when installing python-wtforms:

==> Starting build()...
Traceback (most recent call last):
File "./setup.py", line 5, in <module>
import wtforms
File "/tmp/yaourt-tmp-whitelynx/aur-python-wtforms/src/WTForms-0.4/wtforms/__init__.py", line 11, in <module>
from wtforms import validators, widgets
File "/tmp/yaourt-tmp-whitelynx/aur-python-wtforms/src/WTForms-0.4/wtforms/validators.py", line 15
def __init__(self, message=u'', *args, **kwargs):
^
SyntaxError: invalid syntax
Aborting...
==> ERROR: Makepkg was unable to build python-wtforms.

This can be fixed by changing 'python' to 'python2' in the PKGBUILD.