Package Details: pytrainer 1.12.2-1

Git Clone URL: https://aur.archlinux.org/pytrainer.git (read-only)
Package Base: pytrainer
Description: A tool to log your sport activities.
Upstream URL: https://github.com/pytrainer/pytrainer/wiki
Licenses: GPL
Submitter: None
Maintainer: zoe
Last Packager: zoe
Votes: 22
Popularity: 0.031712
First Submitted: 2006-10-18 16:58
Last Updated: 2018-05-16 16:26

Dependencies (11)

Required by (0)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

xduugu commented on 2011-09-25 19:22

@Henry78
The source tarball is still available.

@dcelasun
I would take it.

dcelasun commented on 2011-09-25 18:29

I'm no longer interested in this package, so if anyone would like to adopt, I can orphan it.

Henry78 commented on 2011-09-25 18:27

pytrainer still needs gtkmozembed, as xduugus patch isn't available any more, pytrainer is borken ATM

lantald commented on 2011-07-18 08:58

@xduugu: Thanks a lot for creating the patch! It is great to be able to use pytrainer again :-D

xduugu commented on 2011-07-18 07:09

I've cleaned up the package a bit and used the patch from svn to replace xulrunner with webkit.
http://www.herosh.com/download/9264089/pytrainer.tar.gz.html

$ sha1sum pytrainer.tar.gz
f543e1ca3eb6e0a854348a85b9bf71ec030241a6 pytrainer.tar.gz

PKGBUILD: http://pastebin.com/HrR3Y62F
pytrainer.sh: http://pastebin.com/TXEPRCUa
replace_gtkmozembed_with_webkit.patch: http://pastebin.com/M7PgDntB

dcelasun commented on 2011-07-15 04:52

@djm: Thanks. I'll update the package as soon as that patch gets included in the stable release.

Anonymous comment on 2011-07-15 03:04

Further to my previous comment, it looks like it has recently been fixed in pytrainer (http://sourceforge.net/apps/trac/pytrainer/ticket/131) and will appear in the next release.

Anonymous comment on 2011-07-15 02:51

I get an error 'ImportError: No module named gtkmozembed' when trying to run pytrainer.

It seems to be due to python2-gtkmozembed being dropped (https://bugs.archlinux.org/task/25103). Reinstalling the old python2-gtkmozembed doesn't help, however - as the bug report says, it apparently needs to be rebuilt against the new xulrunner.

dcelasun commented on 2011-04-29 04:48

@ngoone: Fixed, thanks!

ngoonee commented on 2011-04-29 02:51

Please change dependency to cairo instead of cairo-tee, cairo in [extra] already has enable-tee