Package Details: pyzor 1.0.0-2

Git Clone URL: https://aur.archlinux.org/pyzor.git (read-only, click to copy)
Package Base: pyzor
Description: Detect and block spam using identifying digests of messages.
Upstream URL: https://github.com/SpamExperts/pyzor
Licenses: GPL
Submitter: Snowman
Maintainer: starfry
Last Packager: starfry
Votes: 16
Popularity: 0.27
First Submitted: 2007-03-31 06:16 (UTC)
Last Updated: 2020-07-02 08:36 (UTC)

Latest Comments

bjo commented on 2022-09-23 13:59 (UTC)

1.0.0 is not compatible with python3, so it's not easily changing python2 to python,

bjo commented on 2022-09-23 13:42 (UTC)

Seems broken:

  File "/usr/bin/pyzor", line 408, in <module>
    main()
  File "/usr/bin/pyzor", line 131, in main
    config, options, args = load_configuration()
  File "/usr/bin/pyzor", line 113, in load_configuration
    for key, value in defaults.iteritems():
AttributeError: 'dict' object has no attribute 'iteritems'

L0ric0 commented on 2019-12-13 15:29 (UTC)

could you please change the installation to python3 as python2 will be eol on 01.01.2020. you only need to change python2 to python

zmeYski commented on 2015-04-20 08:31 (UTC)

Hi, looks like there is a new versions. It supports python 3.2+ http://www.pyzor.org/en/release-1-0-0/installation.html#compatibility The update is trivial. Would you care to update this package?

richli commented on 2014-05-29 06:31 (UTC)

I've updated it to version 0.7.0: https://gist.github.com/richli/1afc26451a5a05d10699

starfry commented on 2011-09-07 20:15 (UTC)

updated pkgbuild

starfry commented on 2011-08-21 20:19 (UTC)

I found that this needs to use python2 instead of python. I don't know if that's due to my setup or that the PKGBUILD is wrong. My PKGBUILD is here: http://pastebin.com/vfhi6MNX

Vrob commented on 2010-11-09 12:05 (UTC)

Depends should be changed to python2 since python is now python3.

commented on 2010-03-30 21:09 (UTC)

Tested on 'x86_64' builds and installs fine.