Package Details: q4wine 1.3.10-1

Git Clone URL: https://aur.archlinux.org/q4wine.git (read-only)
Package Base: q4wine
Description: A Qt5 GUI for Wine
Upstream URL: http://sourceforge.net/projects/q4wine/
Licenses: GPL3
Submitter: Barthalion
Maintainer: Jake
Last Packager: Jake
Votes: 17
Popularity: 2.449106
First Submitted: 2018-01-07 17:37
Last Updated: 2018-09-15 21:55

Latest Comments

1 2 Next › Last »

mozo commented on 2018-05-30 12:02

Yes it compiles fine now. Thank you :)

Jake commented on 2018-05-29 20:07

The update to QT 5.11 caused this and it is already fixed in current master: https://github.com/brezerk/q4wine/issues/125

I have added the patch also in the pkgbuild now.

dustball commented on 2018-05-29 18:38

I'd like to add to the recent spam by contributing the actual CMakeOutput.log: https://ptpb.pw/euZh I've used "makepkg -fsir --noconfirm" to build.

mozo commented on 2018-05-29 18:32

Can't compile:

https://pastebin.com/jA9bswQs

tydynrain commented on 2018-05-28 02:30

I get the same build error as DanielH.

DanielH commented on 2018-05-26 17:06

Using yaourt I can't compile q4wine: ... CMake Error at src/qtsingleapplication/CMakeLists.txt:26 (qt5_use_modules): Unknown CMake command "qt5_use_modules".

-- Configuring incomplete, errors occurred! See also "/home/$USER/yaourt-tmp-daniel/aur-q4wine/src/q4wine-1.3.7/CMakeFiles/CMakeOutput.log ... Why CMake doesn't recognize qt5_use_modules command? I don't understand this log...

bartus commented on 2018-05-24 12:31

@SpotlightKid: Check if strip is working (strip -v --strip-unneeded /usr/bin/q4wine -o /tmp/q4wine; du -h /tmp/q4wine), and look if it's called correctly from within makepkg (edit /usr/bin/makepkg and add -xv flag to bash at first line, than makepkg -Rf|&grep strip\ --strip-unneeded).

Jake commented on 2018-05-23 23:27

Thanks for the comments, i have removed the build flag and added qt5-svg now.

@SpotlightKid, it works fine here, results in a 4,3 MB binary, so it must have something to do with your config, i have no idea what though...

bartus commented on 2018-05-23 14:53

build fails in cmake because of missing qt5-svg.

CMake Error at src/CMakeLists.txt:44 (find_package):
  By not providing "FindQt5Svg.cmake" in CMAKE_MODULE_PATH this project has
  asked CMake to find a package configuration file provided by "Qt5Svg", but
  CMake did not find one.

  Could not find a package configuration file provided by "Qt5Svg" with any
  of the following names:

    Qt5SvgConfig.cmake
    qt5svg-config.cmake

  Add the installation prefix of "Qt5Svg" to CMAKE_PREFIX_PATH or set
  "Qt5Svg_DIR" to a directory containing one of the above files.  If "Qt5Svg"
  provides a separate development package or SDK, be sure it has been
  installed.


-- Configuring incomplete, errors occurred!

SpotlightKid commented on 2018-05-23 13:22

When I build this package, the q4wine binary isn't stripped, resulting in a file of 44 MB size, even though I have the 'strip' option enabled in /etc/makepkg.conf (and its output says "Stripping unneeded symbols from binaries and libraries...". Any idea why this is?