Package Details: qbittorrent-git 1:4.5.0alpha1.r605.g4e06a9629-1

Git Clone URL: (read-only, click to copy)
Package Base: qbittorrent-git
Description: An advanced BitTorrent client programmed in C++, based on Qt toolkit and libtorrent-rasterbar (git version)
Upstream URL:
Keywords: bittorrent qt torrent
Licenses: GPL, custom
Conflicts: qbittorrent
Provides: qbittorrent
Submitter: Sevenseven
Maintainer: yurikoles
Last Packager: yurikoles
Votes: 50
Popularity: 0.089054
First Submitted: 2011-06-28 01:40 (UTC)
Last Updated: 2022-09-15 02:35 (UTC)

Required by (19)

Sources (1)

Latest Comments

1 2 3 4 5 6 7 Next › Last »

yurikoles commented on 2022-04-27 01:56 (UTC)

Thanks MarsSeed, I applied your suggestion.

MarsSeed commented on 2022-03-25 22:34 (UTC) (edited on 2022-04-23 12:19 (UTC) by MarsSeed)

The version string is wrong.

For Pacman, 4.5.0alpha1 < 4.5.0 < 4.5.0.alpha1 < 1:4.5.0alpha1.

Please kindly fix the version string creation (change 4.5.0.alpha1 to 4.5.0alpha1), and add an epoch=1 variable to the beginning section of the PKGBUILD to "reset" the version ordering.

This fix is needed so that whenever v4.5.0 stable gets released, Pacman will see pkgver=4.5.0[...] as newer version than pkgver=4.5.0.alpha1[...].

Otherwise Pacman won't update the alpha package to the stable version once that is out.

milkii commented on 2021-01-07 12:35 (UTC)

Getting this at the mo;

configure: error: Package requirements (libtorrent-rasterbar >= 1.2.11) were not met:

Package dependency requirement 'libtorrent-rasterbar >= 1.2.11' could not be satisfied.
Package 'libtorrent-rasterbar' has version '1.2.10', required version is '>= 1.2.11'

katt commented on 2020-08-23 10:31 (UTC)

If anyone is struggling to run this with qt5-base-headless, you need shared-mime-info, posting this partly in case I encounter this ever again.

eschwartz commented on 2017-09-24 17:59 (UTC)

This is true... I generally publish updated pkgver/pkgrel for soname rebuilds (although this time around I was offline over the weekend), but this is hardly required as an AUR standard. The user is expected to know enough to rebuild their AUR packages after events like this.

tuxayo commented on 2017-09-23 20:04 (UTC)

I also had to rebuild libtorrent-rasterbar-1_0-git before rebuilding qbittorrent-git

tuxayo commented on 2017-09-23 19:09 (UTC)

After the update of boost (1.64.0-4 -> 1.65.1-1) the package must be rebuilt.

eschwartz commented on 2017-09-07 22:35 (UTC)

No, you install base-devel as all users are required to do before using makepkg. I am not responsible for working around the fact that you didn't read the basic instructions for using the AUR.