Package Details: qca-qt4 2.1.3-2

Git Clone URL: https://aur.archlinux.org/qca-qt4.git (read-only)
Package Base: qca-qt4
Description: Qt Cryptographic Architecture. Qt4 Build
Upstream URL: http://delta.affinix.com/qca/
Licenses: LGPL
Submitter: geosam
Maintainer: buzo
Last Packager: buzo
Votes: 1
Popularity: 0.137044
First Submitted: 2018-08-22 18:53
Last Updated: 2018-10-17 14:07

Dependencies (10)

Required by (2)

Sources (3)

Latest Comments

buzo commented on 2018-10-17 14:09

I have removed conflicts/provides/replaces now. Does this fix it for you?

Twiki commented on 2018-10-09 08:30

qca-qt4 replaced with extra/qca. kget, okteta, okular, plasma-nm still working flawlessly.

Twiki commented on 2018-10-08 17:47

Looks like your "Required by" list needs a lot more packages added :

[twiki@spacestation ~]# sudo pacman -Rsp qca-qt4 error: failed to prepare transaction (could not satisfy dependencies) :: kget: removing qca-qt4 breaks dependency 'qca' :: okteta: removing qca-qt4 breaks dependency 'qca' :: okular: removing qca-qt4 breaks dependency 'qca' :: plasma-nm: removing qca-qt4 breaks dependency 'qca'

Twiki commented on 2018-10-03 01:05

Because of the conflict with extra/qca, I constantly have to use : sudo pacman -Syyu --ignore qca to update packages. Or else :

[twiki@spacestation ~]# sudo pacman -Syyu [sudo] password for twiki: :: Synchronising package databases... core 135,6 KiB 3,01M/s 00:00 [######################################################################################################] 100% extra 1637,4 KiB 6,15M/s 00:00 [######################################################################################################] 100% community 4,6 MiB 8,34M/s 00:01 [######################################################################################################] 100% :: Starting full system upgrade... :: Replace libx264-10bit with extra/x264? [Y/n] :: Replace qca-qt5 with extra/qca? [Y/n] resolving dependencies... looking for conflicting packages... :: qca and qca-qt4 are in conflict. Remove qca-qt4? [y/N] error: unresolvable package conflicts detected error: failed to prepare transaction (conflicting dependencies) :: qca and qca-qt4 are in conflict [twiki@spacestation ~]#

Info on this package gives me some weired information compared to what is listed here. More specific: Higher "Version" with older "Build Date", different "Required By", different "Packager".

[twiki@spacestation ~]# pacman -Qi qca-qt4 Name : qca-qt4 Version : 2.1.3-11 Description : Qt Cryptographic Architecture Architecture : x86_64 URL : http://delta.affinix.com/qca/ Licenses : LGPL Groups : None Provides : qca qca-gnupg qca-ossl Depends On : qt4 nss Optional Deps : pkcs11-helper: PKCS-11 plugin [installed] botan: botan plugin Required By : kget okteta okular plasma-nm Optional For : None Conflicts With : qca qca-gnupg qca-ossl Replaces : qca qca-gnupg qca-ossl Installed Size : 2,88 MiB Packager : Antonio Rojas arojas@archlinux.org Build Date : di 03 jul 2018 13:05:58 CEST Install Date : di 03 jul 2018 21:36:33 CEST Install Reason : Installed as a dependency for another package Install Script : No Validated By : Signature

arojas commented on 2018-08-29 06:41

Please remove the conflicts/replaces/provides for qca, they no longer make sense and cause issues when using the official qca package.