Package Details: qdecoder 12.0.6-1

Git Clone URL: https://aur.archlinux.org/qdecoder.git (read-only)
Package Base: qdecoder
Description: qDecoder is a CGI library for C/C++ programming language which has been developed since 1996.
Upstream URL: https://wolkykim.github.io/qdecoder/
Licenses: custom
Submitter: Erroneous
Maintainer: Erroneous
Last Packager: Erroneous
Votes: 2
Popularity: 0.000000
First Submitted: 2016-03-30 01:00
Last Updated: 2017-03-05 12:35

Dependencies (1)

Required by (0)

Sources (2)

Latest Comments

Erroneous commented on 2017-03-05 12:40

Thanks for the fix, amish. Let me know if you submit a PR upstream so that I can remove this patch from >12.0.6

@sku1d the 12.0.6 PKGBUILD provides /usr/lib/pkgconfig/qdecoder.pc

amish commented on 2017-03-05 06:43

Makefile.in of upstream is buggy. It does not use DESTDIR for install.

Which lead to non-standard PKGBUILD using pkgdir in configure, make, make install. Which is not the correct way, as it messes up the pkgconfig file with references to pkgdir.

I have created a patch for Makefile.in which fixes the issue:

Patch filename: qdecoder.diff (pastebin)
http://pastebin.com/raw/upaCqKex

New PKGBUILD:
http://pastebin.com/raw/nfTKm9wS

Please update accordingly.

sku1d commented on 2016-06-21 22:04

Thanks for providing this package! It would be great if it would also provide the pkg-config file (that is 'install src/qdecoder.pc' to '/usr/share/pkgconfig/' afaik). Also I cannot see a reason for this package to rely on libfcgi. That does not seem to be the default when compiling qdecoder. So why is that?