Package Details: qdigidoc 3.12.2.1453-1

Git Clone URL: https://aur.archlinux.org/qdigidoc.git (read-only)
Package Base: qdigidoc
Description: Qt based UI application for verifying and signing digital signatures
Upstream URL: http://www.id.ee/
Keywords: esteid
Licenses: LGPL
Submitter: kevku
Maintainer: kevku
Last Packager: kevku
Votes: 6
Popularity: 0.148544
First Submitted: 2012-12-12 12:20
Last Updated: 2016-07-11 14:21

Latest Comments

yupi commented on 2016-02-03 18:13

@mareke
I had the same error. Full update + restart will fix it.

mareke commented on 2016-02-02 18:19

I'm getting error:
crypto/CMakeFiles/qdigidoccrypto.dir/build.make:95: recipe for target 'crypto/CMakeFiles/qdigidoccrypto.dir/CryptoDoc.cpp.o' failed
make[2]: *** [crypto/CMakeFiles/qdigidoccrypto.dir/CryptoDoc.cpp.o] Error 1
CMakeFiles/Makefile2:373: recipe for target 'crypto/CMakeFiles/qdigidoccrypto.dir/all' failed
make[1]: *** [crypto/CMakeFiles/qdigidoccrypto.dir/all] Error 2
Makefile:127: recipe for target 'all' failed
make: *** [all] Error 2

Rozyx commented on 2015-12-21 15:13

@Kallestofeles
Thank you! Your solution works!

pat_brat commented on 2015-12-13 14:20

Scratch that previous comment. I re-installed libdigidocpp despite the fact that it was supposedly up-to-date (with a net upgrade size of -0.06 MB, so maybe something went wrong) and it seems to have installed. So... if anyone has linking problems, try reinstalling the digidoc libs.

pat_brat commented on 2015-12-13 12:44

Can't compile. First, it used to freeze on "[ 76%] Generating TSL.qrc, tl-mp.xml, EE.xml", which it apparently got over, but now I get a linker error on "[ 98%] Linking CXX executable qdigidocclient". 76 lines of code, so I won't paste the whole output, but you can see it on http://pastebin.com/5XgPPr4A ... Has anyone had similar problems?

ggg377 commented on 2015-11-21 13:24

Something is wrong with the dependencies. qt5-tools and qt5-translations are marked necessary for make only, but when you remove them after install (as pacman suggests), qdigidoc won't start because of an xcb error. If you leave these two packages alone, them and their dependencies (cdparanoia, geoclue, gst-plugins-base, libvisual, libxkbcommob-x11, qt5-declarative, qt5-location, qt5-sensors, qt5-webchannel, qt5-webkit, qt5-xmlpatterns) start coming up as orphans when doing package maintenance because pacman doesn't see them as required by any package.

Kallestofeles commented on 2015-10-05 10:18

Works normally.
For public keys use "gpg --recv-keys [KEY]".

Cheers!

kristerv commented on 2015-02-01 22:08

"vaikus", ära mölise. Tee paremini.

But yeah, public key problem with all of these packages:
qdigidoc-3.9.1.1369.tar.gz ... FAILED (unknown public key B339B36D592073D4)

vaikus commented on 2014-12-04 20:48

Tere kevku.

On väga raske õppida pakendama id-kaardi tarkvara?

vaikus commented on 2014-10-18 17:31

https://installer.id.ee/media/sources/

New version libdigidoc-3.9.0.1167

kevku commented on 2014-09-30 07:52

you can use xsd3-bin https://aur.archlinux.org/packages/xsd3-bin/

whimish commented on 2014-09-30 06:56

Doesn't compile anymore with xsd 4 and boost libs 1.56.
Had to downgrade these packages from arch rollback machine to get it compiled.

mehine2 commented on 2013-02-07 13:34

updates didn't help, but I copied and renamed /lib/libxml-security-c.so.17 to /lib/libxml-security-c.so.16 and that help (probably not the correct way).

mehine2 commented on 2013-02-07 13:34

updates didn't help, but I copied and renamed /lib/libxml-security-c.so.17 to /lib/libxml-security-c.so.17 and that help (probably not the correct way).

kevku commented on 2013-02-07 11:36

you need to update the libs too

kevku commented on 2013-02-07 11:35

you need to update xml-security-c before qdigidoc

mehine2 commented on 2013-02-07 09:52

qdigidocclient: error while loading shared libraries: libxml-security-c.so.16: cannot open shared object file: No such file or directory

I have updated both qdigidoc & xml-security-c

kevku commented on 2012-12-13 15:14

right, my bad.

intgr commented on 2012-12-13 10:39

makedepend libpcsclite should be pcsclite, right? pcsclite includes /usr/lib/libpcsclite.so