Package Details: qemu-minimal 2.12.0-1

Git Clone URL: https://aur.archlinux.org/qemu-minimal.git (read-only)
Package Base: qemu-minimal
Description: A generic and open source machine emulator and virtualizer. This is a stripped-down version of the official package and requires only the bare essentials for running on a headless server.
Upstream URL: http://wiki.qemu.org/
Licenses: GPL2, LGPL2.1
Conflicts: qemu, qemu-headless
Provides: qemu, qemu-headless
Submitter: liujed
Maintainer: liujed
Last Packager: liujed
Votes: 5
Popularity: 0.000000
First Submitted: 2014-05-29 16:35
Last Updated: 2018-05-05 05:49

Required by (68)

Sources (6)

Latest Comments

alpha.niner commented on 2016-05-10 20:58

Anyone know if this build precludes audio support when a guest is connected remotely via virt-manager, vnc, etc? Thanks.

BugMaze commented on 2016-02-24 03:39

@liujed :
Thanks for clarifying the issue with pixman library .

I modified your PKGBUILD to build from the git directly and it is compiling right now . Cheers .

liujed commented on 2016-02-24 02:53

BugMaze: Okay, I see what is going on. If pixman is installed on the build system, qemu will link against that; otherwise, it uses an internal version of pixman. Seems easiest to just require pixman as a dependency, as you originally suggested. I am building it now. Once it's tested, I will push an update.

As for qemu-minimal-git, not from me. I wouldn't be using it myself, so I can't guarantee that things would work.

BugMaze commented on 2016-02-23 21:41

@liujed :

Running qemu-system-x86_64 without Pixman throws the following error :

qemu-system-x86_64: error while loading shared libraries: libpixman-1.so.0: cannot open shared object file: No such file or directory

And compiling this package without Pixman did throw a pixman error too . Any chance of getting a qemu-minimal-git package ?

Many thanks .

liujed commented on 2016-02-22 05:23

Thanks for the feedback, BugMaze. pixman doesn't seem to be a dependency. At least, I don't have it installed, and am running qemu-system-x86_64 just fine.

BugMaze commented on 2016-02-22 01:23

Hi . Thanks for updating the package , it is compiling flawlessly now .

Please note that Pixman is a dependency and should be installed for Qemu to work (at least the qemu-system-x86_64 binary) .

Thank you .

liujed commented on 2015-10-01 05:11

Thanks, eduncan911. Just pushed 2.4.0-4, which should fix the error.

eduncan911 commented on 2015-09-26 05:54

Seems that there is a script error with the latest version.

$ sudo pacman -U --debug --verbose qemu-minimal-2.4.0-2-x86_64.pkg.tar

Relevant --debug entries:

debug: executing ". /tmp/alpm_KsQiV6/.INSTALL; post_install 2.4.0-2"
debug: executing "/usr/bin/bash" under chroot "/"
debug: call to waitpid succeeded
error: command failed to execute correctly
debug: returning error 31 from alpm_db_get_pkg : could not find or read package