Package Details: qemu-static 2.7.0-1

Git Clone URL: https://aur.archlinux.org/qemu-static.git (read-only)
Package Base: qemu-static
Description: A generic and open source processor emulator which achieves a good emulation speed by using dynamic translation.
Upstream URL: http://wiki.qemu.org/Index.html
Licenses: GPL2, LGPL2.1
Submitter: sergej
Maintainer: sergej
Last Packager: sergej
Votes: 5
Popularity: 0.008876
First Submitted: 2013-10-11 18:01
Last Updated: 2016-10-24 14:11

Latest Comments

ajs124 commented on 2016-09-03 16:20

updated pkgbuild https://gist.github.com/ajs124/441582f260555e33d82733378e9bc29c

dlin commented on 2014-11-24 06:05

I'm use x86_64, and here are the depends packages.

qemu 2.420-1
glib2-static 2.42.0-1
glibc-static 2.20-2
pcre-static 8.36-1

makepkg failed as following error messages. Any solutions?

(.text+0x10b): warning: Using 'getpwuid_r' in statically linked applications requires at runtime the shared libraries [5/1872]
glibc version used for linking
CC sh4eb-linux-user/target-sh4/helper.o
/usr/lib/libglib-2.0.a(libglib_2_0_la-gutils.o): In function `g_get_user_database_entry':
(.text+0x251): warning: Using 'getpwuid' in statically linked applications requires at runtime the shared libraries from the g
libc version used for linking
/usr/lib/libglib-2.0.a(libglib_2_0_la-gutils.o): In function `g_get_user_database_entry':
(.text+0xd4): warning: Using 'getpwnam_r' in statically linked applications requires at runtime the shared libraries from the
glibc version used for linking
/usr/lib/libglib-2.0.a(libglib_2_0_la-gutils.o): In function `g_get_user_database_entry':
(.text+0x10b): warning: Using 'getpwuid_r' in statically linked applications requires at runtime the shared libraries from the
glibc version used for linking
CC sh4eb-linux-user/target-sh4/cpu.o
CC sh4eb-linux-user/target-sh4/gdbstub.o
LINK sh4eb-linux-user/qemu-sh4eb
/usr/lib/libglib-2.0.a(libglib_2_0_la-gutils.o): In function `g_get_user_database_entry':
(.text+0x251): warning: Using 'getpwuid' in statically linked applications requires at runtime the shared libraries from the g
libc version used for linking
/usr/lib/libglib-2.0.a(libglib_2_0_la-gutils.o): In function `g_get_user_database_entry':
(.text+0xd4): warning: Using 'getpwnam_r' in statically linked applications requires at runtime the shared libraries from the
glibc version used for linking
/usr/lib/libglib-2.0.a(libglib_2_0_la-gutils.o): In function `g_get_user_database_entry':
(.text+0x10b): warning: Using 'getpwuid_r' in statically linked applications requires at runtime the shared libraries from the
glibc version used for linking
==> ERROR: A failure occurred in build().

sergej commented on 2014-10-07 21:09

fixed and updated

meredrica commented on 2014-01-07 11:25

You are missing some dependencies
==> Making package: qemu-static 1.7.0-1 (Tue Jan 7 12:24:40 CET 2014)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Installing missing dependencies...
error: target not found: glib2-static
error: target not found: pcre-static
error: target not found: glibc-static

dlin commented on 2013-12-09 02:10

1.7.0 released, my PKGBUILD https://gist.github.com/dlintw/7866460

dlin commented on 2013-11-09 12:56

Build failed,

QOM debugging yes
GEN config-host.h
CHK version_gen.h
AR libfdt/libfdt.a
ar: two different operation options specified
Makefile:234: recipe for target 'libfdt/libfdt.a' failed
make[1]: *** [libfdt/libfdt.a] Error 1
Makefile:153: recipe for target 'subdir-dtc' failed
make: *** [subdir-dtc] Error 2
==> ERROR: A failure occurred in build().
Aborting...