Package Details: qgis 2.18.4-1

Git Clone URL: https://aur.archlinux.org/qgis.git (read-only)
Package Base: qgis
Description: Geographic Information System (GIS) that supports vector, raster & database formats
Upstream URL: http://qgis.org/
Licenses: GPL
Submitter: td123
Maintainer: Scimmia
Last Packager: Scimmia
Votes: 188
Popularity: 5.434861
First Submitted: 2011-07-22 15:23
Last Updated: 2017-02-25 22:22

Dependencies (39)

Required by (1)

Sources (1)

Pinned Comments

Scimmia commented on 2017-02-25 01:26

After some testing, we're going to try this without qtwebkit. If anyone runs into problems because of this, please let me know.

The versioned makedeps on sip/python2-sip are what are required to build on my machine. 4.19.1 is totally broken, but 4.19 will build for some people and not others. If you have segfaults with 4.19, try an older version. You can then update the system after building with the older version.

Scimmia commented on 2016-05-20 13:03

*IMPORTANT*
I've moved most of the plugin deps to optional deps. Please pay attention to them. Let me know if I missed something.

Latest Comments

jose1711 commented on 2017-03-22 22:18

downgraded packages as suggested but i am still unable to compile qgis:

[ 97%] Built target translations
[ 97%] Generating analysis/sip_analysispart0.cpp, analysis/sip_analysispart1.cpp, analysis/sip_analysispart2.cpp, analysis/sip_analysispart3.cpp

sip: Unable to find file "QtCore/QtCoremod.sip"
make[2]: *** [python/CMakeFiles/python_module_qgis__analysis.dir/build.make:420: python/analysis/sip_analysispart0.cpp] Error 1
make[2]: *** Deleting file 'python/analysis/sip_analysispart0.cpp'
make[1]: *** [CMakeFiles/Makefile2:3360: python/CMakeFiles/python_module_qgis__analysis.dir/all] Error 2
make: *** [Makefile:150: all] Error 2

Acti commented on 2017-03-22 13:24

For some reason i couldn't downgrade the version with "downgrade" tried it with "downgrader" and everything went smooth. Thanks daniel687.

daniel687 commented on 2017-03-21 14:42

!!Finally Got it to work!!

Basically downgraded to the same libs that @markbhp posted before

-Installed package "downgrade" from AUR and downgraded to the following:

-qscintilla-qt4-2.9.4-1
-python2-qscintilla-qt4-2.9.4-1
-python-qscintilla-qt4-common-2.9.4-1
-sip-4.19-1
-python2-sip-4.19-1

EXAMPLE
sudo downgrade {package} (sudo downgrade qscintilla-qt4)


Compilation went successfully.
Qgis on startup gave some errors for missing python libs witch I installed easly with
"pip2 install {package}"


Hope that this will been usefull


Acti commented on 2017-03-21 13:42

Same problem like vgivanovic.

==> Building and installing package
==> Install or build missing dependencies for qgis:
[sudo] password for acti:
error: target not found: sip<4.19.1
error: target not found: python2-sip<4.19.1
error: target not found: python-qscintilla-qt4-common<2.10
error: target not found: python2-qscintilla-qt4<2.10
error: target not found: qscintilla-qt4<2.10
==> Restart building qgis ? [y/N]

vgivanovic commented on 2017-03-20 15:22

Just FYI:

==> Install or build missing dependencies for qgis:
error: target not found: sip<4.19.1
error: target not found: python2-sip<4.19.1
error: target not found: python-qscintilla-qt4-common<2.10
error: target not found: python2-qscintilla-qt4<2.10
error: target not found: qscintilla-qt4<2.10
==> Restart building qgis ? [y/N]
==> -----------------------------
==>
==> ERROR: unable to update
~> pacman -Q sip python2-sip python-qscintilla-qt4-common python2-qscintilla-qt4
sip 4.19.1-1
python2-sip 4.19.1-1
python-qscintilla-qt4-common 2.10-1
python2-qscintilla-qt4 2.10-1

I will wait until any breakage with dependencies if fixed.

parchd commented on 2017-03-16 16:00

The dependencies here require qscintilla-qt4 < 2.10, but this is no longer available in the repos (it has been updated to 2.10).

Edit: sorry for repeating what has already been pointed out. I got confused by the pinned comments and thought there had been no comment activity since 2017-02-25.

MethodicOwl commented on 2017-03-14 11:33

@markbhp thank you for opening my eyes!!!
I had sip-4.18.1 python2-sip-4.18.1 and i was confusing sip-4.19.1-1 with sip-4.19.1 and the same to python2-sip!!

After that i was able to makepkg -s and install it with pacman! about time too :P

mhaffner commented on 2017-03-14 01:54

@markbhp That worked for me as well. Thanks for putting in the work to figure out a workaround!

greenisagoodcolo commented on 2017-03-13 16:51

@markbhp that did it. Thank you!

greenisagoodcolo commented on 2017-03-13 16:51

@markbhp that did it. Thank you!

All comments