Package Details: qgnomeplatform 0.6.0-2

Git Clone URL: https://aur.archlinux.org/qgnomeplatform.git (read-only, click to copy)
Package Base: qgnomeplatform
Description: Qt Platform Theme aimed to accomodate as much of GNOME settings as possible
Upstream URL: https://github.com/MartinBriza/QGnomePlatform
Keywords: GNOME Qt
Licenses: LGPL2.1
Submitter: aimileus
Maintainer: jaylectric
Last Packager: jaylectric
Votes: 18
Popularity: 1.44
First Submitted: 2018-02-04 11:04
Last Updated: 2019-11-24 13:08

Latest Comments

Jaakkonen commented on 2019-12-21 19:50

Building this required gdk and glib2 to be in include path. Without those it complains about not finding gdk/gdk.h or gio/gio.h

I fixed this by modifing the source codes common/common.pro to have gdk-3.0 in the PKGCONFIG section. I also posted a issue into the upstream github repo: [https://github.com/FedoraQt/QGnomePlatform/issues/53]

EDIT:
This could also be fixed by adding xorgproto dependency as it fixes something in gtk+-3.0 that gets glib2 and gdk-3.0 included :)

jaylectric commented on 2019-11-24 13:10

Thanks bbx0, I have added qt5-x11extras as a dependency.

bbx0 commented on 2019-11-24 12:32

Thanks for updating! I had to add qt5-x11extras as additional dependency otherwise the build fails in a clean chroot with:

Info: creating stash file /build/qgnomeplatform/src/QGnomePlatform-0.6.0/.qmake.stash
cd common/ && ( test -e Makefile || /usr/bin/qmake-qt5 -o Makefile /build/qgnomeplatform/src/QGnomePlatform-0.6.0/common/common.pro ) && make -f Makefile 
Project ERROR: Unknown module(s) in QT: x11extras
make: *** [Makefile:49: sub-common-make_first] Error 3

shaneramone commented on 2019-11-02 00:05

This has been incorrectly flagged out-of-date. Version 0.5.90 is a pre-release. Version 0.5 is tagged as the latest release on Github.