Package Details: qgroundcontrol-git r14118.0871b019d-3

Git Clone URL: https://aur.archlinux.org/qgroundcontrol-git.git (read-only)
Package Base: qgroundcontrol-git
Description: Micro air vehicle ground control station.
Upstream URL: http://qgroundcontrol.org/
Licenses: GPL3
Submitter: zvyn
Maintainer: pryre
Last Packager: pryre
Votes: 8
Popularity: 0.000000
First Submitted: 2014-02-07 03:20
Last Updated: 2019-05-01 02:54

Latest Comments

1 2 3 Next › Last »

pryre commented on 2019-04-17 11:11

Hi All,

I've adopted the package and will be doing my best to keep it functional. I may have missed some build dependencies, so let me know if anything is missing.

The version bump should be a once-off event, as the package should be quite self-sustaining. The main change was to split this out so it is possible to have the other qgroundcontrol packages available in the AUR all installed at the same time. hopefully the changes made are not noticeable.

Please remember that you will have to periodically update the package manually as it is a "-git" package, and only pulls the latest version when you first install it. The package won't be version-bumped unless build changes are required.

anselmolsm commented on 2017-04-29 18:42

Build fixed, execution fails using the symbolic link /usr/bin/qgroundcontrol-git . /opt/qgroundcontrol-git/qgroundcontrol-start.sh works, sometimes fails though.

Upstream focused on AppImage daily builds, perhaps a PKGBUILD should be created to track that.

Again, as I said before, if anyone wants to maintain this, please let me know.
Also, patches are always welcome.

kikislater commented on 2017-04-26 11:18

Please update

anselmolsm commented on 2016-07-28 15:05

If there is anyone willing to become the maintainer of this package, please let me know.

anselmolsm commented on 2016-07-03 14:29

The update mentioned in my previous comment was submitted a few weeks ago.

The plan is to modify the PKGBUILD to use the Qt version recommended by the community (5.5.1), as QGC has known issues with newer Qt versions.

anselmolsm commented on 2016-05-09 11:08

PKGBUILD needs to be updated, indeed. I haven't done so since I adopted the package, will do. Thanks for pointing it out, Scimmia.

Scimmia commented on 2016-05-03 15:49

Why is this still using the ancient PKGBUILD template? Please see https://wiki.archlinux.org/index.php/VCS_package_guidelines

anselmolsm commented on 2016-02-13 14:02

Adopted it, tks.
Those with build problems: please read my comment with a patch to fix that. I'll update this PKGBUILD as soon as I can (sent from mobile).

zvyn commented on 2016-02-13 08:18

anselmolsm: I disowned it, thanks for taking over!

anselmolsm commented on 2016-02-09 14:14

zvyn: Yep, I can maintain this. Tks.