Package Details: qhangups 1.8.1-1

Git Clone URL: https://aur.archlinux.org/qhangups.git (read-only, click to copy)
Package Base: qhangups
Description: Alternative client for Google Hangouts written in PyQt
Upstream URL: https://github.com/xmikos/qhangups
Licenses: GPL3
Submitter: Mikos
Maintainer: Mikos
Last Packager: Mikos
Votes: 13
Popularity: 0.000000
First Submitted: 2014-09-26 14:04
Last Updated: 2016-10-17 23:28

Latest Comments

« First ‹ Previous 1 2 3 4

Stunts commented on 2014-09-29 12:55

The package now builds ootb, but I am still getting the same error with conflicting Qt4 and Qt5.
I will look further into it tonight and let you know my findings. But I suspect it might be related with quamash being build with qt5 and qhangups with qt4...

Mikos commented on 2014-09-29 12:52

Updated :-) Try it now...

Mikos commented on 2014-09-29 12:36

I can't reproduce it, it works for me with latest Git revision of Quamash and PyQt4.

Can you try it with latest Git revision of QHangups and Hangups? I have made some changes there since version 1.1 (I would update PKGBUILD soon)

Stunts commented on 2014-09-29 12:21

This package requires a change in the PKGBUILD to build:
python-quamash -> python-quamash-git

Even after doing this, it still fails to run with:

Traceback (most recent call last):
File "/usr/bin/qhangups", line 4, in <module>
from qhangups import qhangups
File "/usr/lib/python3.4/site-packages/qhangups/qhangups.py", line 9, in <module>
from quamash import QEventLoop
File "/usr/lib/python3.4/site-packages/quamash/__init__.py", line 29, in <module>
QtCore = __import__(QtModuleName + '.QtCore', fromlist=(QtModuleName,))
RuntimeError: the PyQt5.QtCore and PyQt4.QtCore modules both wrap the QObject class