Package Details: qmplay2 20.07.04-1

Git Clone URL: https://aur.archlinux.org/qmplay2.git (read-only, click to copy)
Package Base: qmplay2
Description: QMPlay2 is a video and audio player which can play most formats and codecs
Upstream URL: https://github.com/zaps166/QMPlay2
Keywords: ass audio chiptune ffmpeg media mod movie player qt srt subtitles video youtube
Licenses: LGPL
Submitter: mrbit
Maintainer: zaps166
Last Packager: zaps166
Votes: 33
Popularity: 0.83
First Submitted: 2012-10-13 22:02
Last Updated: 2020-07-04 20:21

Dependencies (24)

Required by (0)

Sources (1)

Pinned Comments

zaps166 commented on 2017-06-19 20:07

Please report all non Arch Linux packaging issues here: https://github.com/zaps166/QMPlay2/issues

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

zaps166 commented on 2014-05-23 09:56

Ilya87: Could you send me movie (or only fragment), which has incorrect field order flag? I think that field order flag does nothing without deinterlacing, so I must see that movie.

zaps166 commented on 2014-05-23 09:51

OK, VDPAU doesn't work. I don't know why, probably this is ffmpeg-git bug (VLC has the same crash).

You can apply this patch for ffmpeg-git (not for working FFMpeg from official repos, because some movies are less smooth in 1 thread (I don't know why :D)):

--- QMPlay2-src-orig/src/modules/FFMpeg/FFDecVDPAU.cpp 2014-02-22 21:53:12.000000000 +0100
+++ QMPlay2-src/src/modules/FFMpeg/FFDecVDPAU.cpp 2014-05-23 11:43:31.310613570 +0200
@@ -48,7 +48,7 @@
codec_ctx->hwaccel_context = av_mallocz( sizeof( AVVDPAUContext ) );
( ( AVVDPAUContext * )codec_ctx->hwaccel_context )->decoder = ( ( VDPAUWriter * )hwAccelWriter )->getVdpDecoder();
( ( AVVDPAUContext * )codec_ctx->hwaccel_context )->render = ( ( VDPAUWriter * )hwAccelWriter )->getVdpDecoderRender();
- codec_ctx->thread_count = LIBAVCODEC_VERSION_MAJOR < 55 ? 1 : 3;
+ codec_ctx->thread_count = 1;//LIBAVCODEC_VERSION_MAJOR < 55 ? 1 : 3;
codec_ctx->get_buffer = HWAccelHelper::get_buffer;
codec_ctx->release_buffer = HWAccelHelper::release_buffer;
codec_ctx->get_format = get_format;

zaps166 commented on 2014-05-23 09:50

OK, VDPAU doesn't work. I don't know why, probably this is ffmpeg-git bug (VLC has the same crash).

You can apply this patch for ffmpeg-git (not for working FFMpeg from official repos, because some movies are less smooth in 1 thread (I don't know why :D)):

--- QMPlay2-src/src/modules/FFMpeg/FFDecVDPAU.cpp 2014-05-23 11:43:31.310613570 +0200
+++ QMPlay2-src-orig/src/modules/FFMpeg/FFDecVDPAU.cpp 2014-02-22 21:53:12.000000000 +0100
@@ -48,7 +48,7 @@
codec_ctx->hwaccel_context = av_mallocz( sizeof( AVVDPAUContext ) );
( ( AVVDPAUContext * )codec_ctx->hwaccel_context )->decoder = ( ( VDPAUWriter * )hwAccelWriter )->getVdpDecoder();
( ( AVVDPAUContext * )codec_ctx->hwaccel_context )->render = ( ( VDPAUWriter * )hwAccelWriter )->getVdpDecoderRender();
- codec_ctx->thread_count = 1;//LIBAVCODEC_VERSION_MAJOR < 55 ? 1 : 3;
+ codec_ctx->thread_count = LIBAVCODEC_VERSION_MAJOR < 55 ? 1 : 3;
codec_ctx->get_buffer = HWAccelHelper::get_buffer;
codec_ctx->release_buffer = HWAccelHelper::release_buffer;
codec_ctx->get_format = get_format;

Ilya87 commented on 2014-05-22 21:24

This bug appears when VDPAU decoding enabled (and consequently is used for decoding).
P. S. Feature request - add please option (if possible) to set explicitly field order not only when deinterlacing filter is enabled and for VDPAU, because there are some videos that have wrong field order flag and decoding without correct flag leads to ugly picture without deinterlacing and ugly picture with VDPAU deinterlacing.

Ilya87 commented on 2014-05-22 21:22

This bug appears when VDPAU decoding enabled (and consequently is used for decoding).
P. S. Feature request - add please option (if possible) to set explicitly field order not only when deinterlacing filter is enabled and for VDPAU, because there are some videos that have wrong field order flag and decoding with or without correct flags leading to ugly picture without deinterlacing and ugly picture with VDPAU deinterlacing.

zaps166 commented on 2014-05-22 11:31

I compiled ffmpeg-git and qmplay2 and it works correctly. I can't fix bug which is unavailable for me. Could you tell me more about this API change?

Ilya87 commented on 2014-05-22 00:07

This commit is obviously in official ffmpeg's repo, that means QMPlay2 can't oark with ffmpeg-git. Even after recompilation of QMPlay2 it produces the same error. The commit was about API change.

zaps166 commented on 2014-05-21 13:40

This patch modifies libavutil/utils.c, but QMPlay2 crashes at assert in libavcodec/utils.c. I can't compile QMPlay2 with 502512ea0f179165782777265f441d4061ff6012 commit (it seems like libav, but QMPlay2 needs ffmpeg). You must recompile QMPlay2 after updating ffmpeg, otherwise you can have strange software behaviour.

Ilya87 commented on 2014-05-20 18:20

http://git.videolan.org/?p=ffmpeg.git;a=commit;h=502512ea0f179165782777265f441d4061ff6012 - This commit crashes QMPlay2:
Assertion desc->flags & (1 << 4) failed at libavcodec/utils.c:707
[20 may 2014 22:11:07] Program przerwał działanie (SIGABRT)

mrbit commented on 2014-03-08 20:17

Thanks zaps166, done.