Package Details: qps 2.5.0-1

Git Clone URL: https://aur.archlinux.org/qps.git (read-only, click to copy)
Package Base: qps
Description: a visual process manager, an X11 version of 'top' or 'ps'.
Upstream URL: https://github.com/lxqt/qps
Licenses: GPL
Submitter: Barthalion
Maintainer: FredBezies
Last Packager: FredBezies
Votes: 16
Popularity: 0.79
First Submitted: 2018-01-07 16:39 (UTC)
Last Updated: 2022-04-24 15:01 (UTC)

Pinned Comments

FredBezies commented on 2022-04-20 08:25 (UTC)

Note: until LXQt 1.1 is pushed to stable repository, qps 2.5.0 will not be released.

Latest Comments

FredBezies commented on 2022-04-20 08:25 (UTC)

Note: until LXQt 1.1 is pushed to stable repository, qps 2.5.0 will not be released.

csts commented on 2021-11-10 08:37 (UTC)

@FredBezies I checked today and already all dependencies were updated, qps installs fine. Thanks again.

pic

FredBezies commented on 2021-11-09 14:13 (UTC)

@csts: as of November 9th, 2021 LXQt 1.0.0 is in testing repository. It will be fixed in a few days when LXQt 1.0.0 lands on stable repository.

csts commented on 2021-11-09 13:33 (UTC)

qps-git needs these -I'm trying it now:

  :: New dependencies will be installed from AUR:
 liblxqt-git (for qps-git)                        -> 1:0.17.0.2.g7fb82bc-2
 libqtxdg-git (for liblxqt-git)                   -> 3.3.0.3.g7f32cc7-1
 lxqt-build-tools-git (for qps-git, liblxqt-git, libqtxdg-git)     -> 0.3.2-1

csts commented on 2021-11-09 13:30 (UTC)

  :: New dependencies will be installed from repository:
 libkscreen (for lxqt-config)                     -> 5.23.2-1       0.35 MiB
 lxqt-build-tools (for qps)                       -> 0.9.0-1        0.02 MiB
 lxqt-config (for qps)                            -> 0.17.1-1       0.47 MiB
 lxqt-themes (for lxqt-config)                    -> 0.17.0-1       3.09 MiB

csts commented on 2021-11-09 13:29 (UTC)

I use the first mirror from here -it's dated:
https://archlinux.org/mirrors/status/#successful

  -- Detecting CXX compile features
-- Detecting CXX compile features - done
CMake Error at CMakeLists.txt:24 (find_package):
  Could not find a configuration file for package "lxqt" that is compatible
  with requested version "1.0.0".

  The following configuration files were considered but not accepted:

    /usr/share/cmake/lxqt/lxqt-config.cmake, version: 0.17.0

FredBezies commented on 2021-05-04 10:08 (UTC)

@fow0ryl : looks like your mirror is outdated. https://archlinux.org/packages/community/x86_64/lxqt-config/ -> 0.17.1 pushed on May 1st, 2021.

This is why your building process is broken.

fow0ryl commented on 2021-05-04 09:47 (UTC) (edited on 2021-05-04 09:49 (UTC) by fow0ryl)

unable to build qps 2.3.0-1 ...

CMake Error at CMakeLists.txt:24 (find_package):
Could not find a configuration file for package "lxqt" that is compatible
with requested version "0.17.0".
The following configuration files were considered but not accepted:
/usr/share/cmake/lxqt/lxqt-config.cmake, version: 0.16.0

jogai commented on 2020-11-07 18:50 (UTC)

Oh, no problem. it's just that I use topgrade, and that tries to update my aur packages each time. I'll wait, no problem.

FredBezies commented on 2020-11-07 10:18 (UTC)

@jogai: I pushed qps 2.2.0 a little too fast. LXQt packages are still in community-testing as of November 7th, 2020. Please wait until LXQt 0.16 is in community to build qps 2.2.0

Sorry for pushing this update too soon!

jogai commented on 2020-11-07 09:43 (UTC) (edited on 2020-11-07 09:44 (UTC) by jogai)

I cleaned yay first to be sure, and removed qps with -Rscn switch, but when I try to install it gives me:

    ==> Removing existing $srcdir/ directory...
    ==> Extracting sources...
      -> Extracting qps-2.2.0.tar.xz with bsdtar
    bsdtar: Failed to set default locale
    ==> Sources are ready.
    ==> Making package: qps 2.2.0-1 (Sat Nov  7 10:38:19 2020)
    ==> Checking runtime dependencies...
    ==> Checking buildtime dependencies...
    ==> WARNING: Using existing $srcdir/ tree
    ==> Removing existing $pkgdir/ directory...
    ==> Starting build()...
    -- The C compiler identification is GNU 10.2.0
    -- The CXX compiler identification is GNU 10.2.0
    -- Detecting C compiler ABI info
    -- Detecting C compiler ABI info - done
    -- Check for working C compiler: /usr/bin/cc - skipped
    -- Detecting C compile features
    -- Detecting C compile features - done
    -- Detecting CXX compiler ABI info
    -- Detecting CXX compiler ABI info - done
    -- Check for working CXX compiler: /usr/bin/c++ - skipped
    -- Detecting CXX compile features
    -- Detecting CXX compile features - done
    CMake Error at CMakeLists.txt:24 (find_package):
      Could not find a configuration file for package "lxqt" that is compatible
      with requested version "0.16.0".

      The following configuration files were considered but not accepted:

        /usr/share/cmake/lxqt/lxqt-config.cmake, version: 0.15.1



    -- Configuring incomplete, errors occurred!
    See also "/home/jogai/.cache/yay/qps/src/build/CMakeFiles/CMakeOutput.log".
    ==> ERROR: A failure occurred in build().
        Aborting...
    error making: qps

ranger commented on 2020-05-09 16:54 (UTC)

Could you please add liblxqt as a dependency? qps won't start without it

"qps: error while loading shared libraries: liblxqt.so.0"

FredBezies commented on 2019-01-26 12:20 (UTC)

Lxqt 0.14.0 is needed for qps 1.19.0. Sorry for the annoyance.

koro666 commented on 2018-09-03 20:18 (UTC)

Could you please add i686 to the supported architectures?

I tested it and it works fine.

yan12125 commented on 2018-05-14 13:23 (UTC)

FYI: The upstream project is moved to https://github.com/lxqt/qps

khau commented on 2018-02-13 17:23 (UTC)

@FredBezies Thanks, builds perfectly fine now.

FredBezies commented on 2018-02-13 08:12 (UTC)

@Khau : thanks for the report. Qt5-tools was missing in makedepends. I think you can get it build now.

khau commented on 2018-02-12 23:55 (UTC)

Build failure - haven't had a chance to track down the cause or a fix.

CMake Error at /usr/lib64/cmake/Qt5/Qt5Config.cmake:28 (find_package): Could not find a package configuration file provided by "Qt5LinguistTools" with any of the following names:

Qt5LinguistToolsConfig.cmake
qt5linguisttools-config.cmake

Add the installation prefix of "Qt5LinguistTools" to CMAKE_PREFIX_PATH or set "Qt5LinguistTools_DIR" to a directory containing one of the above files. If "Qt5LinguistTools" provides a separate development package or SDK, be sure it has been installed. Call Stack (most recent call first): CMakeLists.txt:31 (find_package)