Package Details: qt4 4.8.7-31

Git Clone URL: https://aur.archlinux.org/qt4.git (read-only)
Package Base: qt4
Description: A cross-platform application and UI framework
Upstream URL: https://www.qt.io
Licenses: custom, GPL3, LGPL, FDL
Conflicts: qt
Replaces: qt<=4.8.4
Submitter: arojas
Maintainer: dviktor
Last Packager: dviktor
Votes: 28
Popularity: 3.43
First Submitted: 2019-05-01 11:51
Last Updated: 2019-07-29 18:11

Dependencies (29)

Required by (676)

Sources (20)

Pinned Comments

dviktor commented on 2019-06-18 12:50

Binary version for latest version (4.8.7-31) with PGP signature is available here

eschwartz commented on 2019-05-09 13:24

@semeion,

qt4 was expelled from the official repositories due to https://lists.archlinux.org/pipermail/arch-dev-public/2019-April/029560.html

It will not be restored, because software needs to stop using qt4. It's fine for people to still use it via the AUR if they have old software that is not ported, but the proper solution is to get that software ported to qt5.

"It takes a long time to compile" is not a reason to move it to community.

@xuanruiqi,

Only Developers and Trusted Users have access to pkgbuild.com, and we will not be uploading qt4 there. If we wanted qt4, we would upload it to community, but we don't -- we have managed to move every package still being actively maintained in the official repos, over to qt5, and we want to stay that way.

...

Again, the proper long-term solution is to get software ported over to qt5.

dviktor commented on 2019-05-05 17:49

For those who have problems with ‘std::tr1’ has not been declared error: build in clean chroot with extra-x86_64-build script.

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 Next › Last »

twisted-space commented on 2019-05-04 17:53

@dviktor I added -g++:QMAKE_CXXFLAGS += -std=gnu++98 to /JavaScriptCore.pro as directed, still fails with the same error.

FMB commented on 2019-05-04 16:31

Same problem as xuanruiqi and MickeyRat, default makepkg.conf too.

dviktor commented on 2019-05-04 16:19

Please try to add *-g++*:QMAKE_CXXFLAGS += -std=gnu++98 in src/3rdparty/webkit/Source/JavaScriptCore/JavaScriptCore.pro file at line 220 (just before lessThan(QT_GCC_MAJOR_VERSION, 5) { block) and tell me your results.

twisted-space commented on 2019-05-04 15:48

I'm having the same problem as MickeyRat, gcc version 8.3.0, default makepkg.conf

dviktor commented on 2019-05-04 15:19

@MickeyRat @xuanruiqi what gcc version do you have?

yan12125 commented on 2019-05-04 13:44

I can confirm this package builds fine with extra-x86_64-build now.

dviktor commented on 2019-05-04 13:38

@MickeyRat please check if you have nonstandard compilation flags set by default in makepkg.conf. This package should build fine with default settings.

mipi commented on 2019-05-04 13:30

For me, it works now :) Thx!

MickeyRat commented on 2019-05-04 13:01

Same here ./wtf/TypeTraits.h:186:69: error: ‘std::tr1’ has not been declared template<typename T> struct HasTrivialConstructor : public std::tr1::has_trivial_constructor<T> { }; ^~~ ./wtf/TypeTraits.h:186:74: error: expected ‘{’ before ‘has_trivial_constructor’ emplate<typename T> struct HasTrivialConstructor : public std::tr1::has_trivial_constructor<T> { }; ^~~~~~~~~~~~~~~~~~~~~~~

./wtf/TypeTraits.h:187:68: error: ‘std::tr1’ has not been declared template<typename T> struct HasTrivialDestructor : public std::tr1::has_trivial_destructor<T> { }; ^~~ ./wtf/TypeTraits.h:187:73: error: expected ‘{’ before ‘has_trivial_destructor’ template<typename T> struct HasTrivialDestructor : public std::tr1::has_trivial_destructor<T> { }; ^~~~~~~~~~~~~~~~~~~~~~

yarr/YarrInterpreter.cpp: In member function ‘bool JSC::Yarr::Interpreter::backtrackParenthesesOnceEnd(JSC::Yarr::ByteTerm&, JSC::Yarr::Interpreter::DisjunctionContext)’: yarr/YarrInterpreter.cpp:707:13: warning: this statement may fall through [-Wimplicit-fallthrough=] if (backTrack->begin == notFound) { ^~ yarr/YarrInterpreter.cpp:711:9: note: here case QuantifierNonGreedy: ^~~~ make[2]: [Makefile.WebKit:1062: .obj/release-static/YarrInterpreter.o] Error 1 make[2]: Leaving directory '/home/mickeyrat/builds/qt4/src/qt-everywhere-opensource-src-4.8.7/src/3rdparty/webkit/Source/JavaScriptCore' make[1]: [Makefile.WebKit:43: sub-JavaScriptCore-JavaScriptCore-pro-make_default-ordered] Error 2 make[1]: Leaving directory '/home/mickeyrat/builds/qt4/src/qt-everywhere-opensource-src-4.8.7/src/3rdparty/webkit/Source' make: ** [Makefile:747: sub-webkit-make_default-ordered] Error 2 ==> ERROR: A failure occurred in build(). Aborting...

dviktor commented on 2019-05-04 12:01

@xuanruiqi Check if you have nonstandard CXXOPTS set in makepkg.conf. Seems like this problem is well-known for a long time ago (see here and here)

I can't reproduce your bug. Just recheked