Package Details: qt5.6 5.6.2-4

Git Clone URL: https://aur.archlinux.org/qt5.6.git (read-only)
Package Base: qt5.6
Description: A cross-platform application and UI framework
Upstream URL: http://qt-project.org/
Licenses: custom, GPL3, LGPL, FDL
Submitter: drhooves
Maintainer: None
Last Packager: drhooves
Votes: 0
Popularity: 0.000000
First Submitted: 2017-03-03 08:09
Last Updated: 2017-05-22 17:30

Dependencies (55)

Sources (1)

Latest Comments

poikilos commented on 2017-06-09 13:05

Doesn't build (due to same error probably but I can't read haagch's comment from 2017-05-23, since the build errors were in German) as of yesterday:
/aur-qt5.6/src/qt-everywhere-opensource-src-5.6.2/qtwebengine/src/3rdparty/chromium/third_party/WebKit/Source/wtf/LinkedHashSet.h:503:5: error: there are no arguments to ‘swapAnchor’ that depend on a template parameter, so a declaration of ‘swapAnchor’ must be available [-fpermissive]
swapAnchor(m_anchor, other.m_anchor);
^~~~~~~~~~ /home/FBM/jgustafson/tmp/yaourt-tmp-jgustafson/aur-qt5.6/src/qt-everywhere-opensource-src-5.6.2/qtwebengine/src/3rdparty/chromium/third_party/WebKit/Source/wtf/LinkedHashSet.h:503:5: note: (if you use ‘-fpermissive’, G++ will accept your code, but allowing the use of an undeclared name is deprecated)

haagch commented on 2017-06-03 11:16

Never mind, it worked now.

Mysterious.

haagch commented on 2017-05-23 20:43

So this doesn't build. I think that's the error that breaks the build:

/home/chris/oldhome/build/qt5.6/src/qt-everywhere-opensource-src-5.6.2/qtwebengine/src/3rdparty/chromium/third_party/WebKit/Source/wtf/LinkedHashSet.h: In Elementfunktion »void WTF::LinkedHashSet<Value, HashFunctions, HashTraits, Allocator>::swap(WTF::LinkedHashSet<Value, HashFunctions, HashTraits, Allocator>&)«:
/home/chris/oldhome/build/qt5.6/src/qt-everywhere-opensource-src-5.6.2/qtwebengine/src/3rdparty/chromium/third_party/WebKit/Source/wtf/LinkedHashSet.h:503:5: Fehler: es gibt keine Argumente für »swapAnchor«, die von einem Templateparameter abhängen, weshalb eine Deklaration von »swapAnchor« verfügbar sein muss [-fpermissive]
swapAnchor(m_anchor, other.m_anchor);
^~~~~~~~~~

drhooves commented on 2017-04-05 11:30

Thanks for the heads-up, I will adjust the PKGBUILD as soon as it hits core/extra.

haagch commented on 2017-04-01 09:38

With OpenSSL 1.1 installed, this PKGBUILD needs the openssl-1.0 package and these two lines:

echo "INCLUDEPATH += /usr/include/openssl-1.0" >> qtbase/src/network/network.pro
export OPENSSL_LIBS='-L/usr/lib/openssl-1.0 -lssl -lcrypto'

See the current qt5 archlinux package: https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/qt5-base#n68