Package Details: qt51-translations 5.1.1-7

Git Clone URL: https://aur.archlinux.org/qt51.git (read-only)
Package Base: qt51
Description: A cross-platform application and UI framework (Translations) (5.1.x)
Upstream URL: http://qt-project.org/
Licenses: custom, GPL3, LGPL, FDL
Groups: qt51
Submitter: ftschindler
Maintainer: ftschindler
Last Packager: ftschindler
Votes: 1
Popularity: 0.000000
First Submitted: 2015-01-17 20:27
Last Updated: 2017-02-15 08:50

Dependencies (31)

Required by (1)

Sources (16)

Latest Comments

jose1711 commented on 2019-04-12 16:32

FWIW an attempt to compile using gcc6 (6.5.0-2) fails with a different error:

Platform/CoreIPC/ArgumentDecoder.h: In instantiation of ‘bool CoreIPC::ArgumentDecoder::bufferIsLargeEnoughToContain(size_t) const [with T = char16_t; size_t = long unsigned int]’:
Platform/CoreIPC/ArgumentCoders.cpp:114:9:   required from ‘bool CoreIPC::decodeStringText(CoreIPC::ArgumentDecoder*, uint32_t, WTF::String&) [with CharacterType = char16_t; uint32_t = unsigned int]’
Platform/CoreIPC/ArgumentCoders.cpp:147:59:   required from here
../WTF/wtf/Assertions.h:328:47: error: size of array is negative
 #define COMPILE_ASSERT(exp, name) typedef int dummy##name [(exp) ? 1 : -1]
                                               ^
Platform/CoreIPC/ArgumentDecoder.h:79:9: note: in expansion of macro ‘COMPILE_ASSERT’
         COMPILE_ASSERT(WTF::IsArithmetic<T>::value, type_must_have_known_encoded_size);
         ^~~~~~~~~~~~~~

ftschindler commented on 2019-04-10 20:08

Thx for reporting. Let me know once you find a solution, I will then update the PKGBUILD accordingly.

jose1711 commented on 2019-04-10 09:39

fails to build

In file included from ../../include/QtCore/qglobal.h:1,
                 from global/qt_pch.h:58:
thread/qmutex_linux.cpp: In function ‘void checkElapsedTimerIsTrivial()’:
thread/qmutex_linux.cpp:63:26: error: ‘has_trivial_default_constructor’ is not a member of ‘std’
     Q_STATIC_ASSERT(std::has_trivial_default_constructor<QT_PREPEND_NAMESPACE(QElapsedTimer)>::value);
                          ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
../../include/QtCore/../../src/corelib/global/qglobal.h:645:55: note: in definition of macro ‘Q_STATIC_ASSERT’
 #define Q_STATIC_ASSERT(Condition) static_assert(bool(Condition), #Condition)
..

ftschindler commented on 2017-02-15 08:50

@Maxr: thanks for spotting, should be fixed!

Maxr commented on 2017-02-13 12:53

Im getting a 404 error on trying to build this.

ftschindler commented on 2015-01-17 20:36

Note that the PKGBUILD of the qt51 group builds all packages at once. So if you need more than one package of this group it makes sense to manually download the source tarball and call makepkg, as opposed to using pacaur or the like...

ftschindler commented on 2015-01-17 20:32

There is an issue with qtcreator (>= 3) and I require the last qtcreator before the 3 series (which I provide in qtcreator28). qtcreator-2.8, however, depends on qt-5.1.1, which I provide in this package. Everything is installed to /opt/qt51 and the file /opt/qt51.PATH defines the required pathes for dependent programs. This package is maintained under https://github.com/ftalbrecht/aur, pull requests are welcome!