Package Details: qtads 2.1.7-1

Git Clone URL: https://aur.archlinux.org/qtads.git (read-only)
Package Base: qtads
Description: A Qt-based interpreter for TADS text adventures. Support TADS 2 and 3, both for text-only and multimedia adventures.
Upstream URL: http://qtads.sourceforge.net/
Licenses: GPL
Submitter: 3ED_0
Maintainer: 3ED_0
Last Packager: 3ED_0
Votes: 2
Popularity: 0.000011
First Submitted: 2015-08-22 09:45
Last Updated: 2016-03-02 13:39

Latest Comments

krouziciorel commented on 2017-11-29 08:53

This package can not be installed today, in the middle of the compilation there is an error:

tads3/tct3stm.cpp: In static member function ‘static void CTPNVarIn::gen_iter_init(CTcPrsNode*, int, const char*)’:
tads3/tct3stm.cpp:318:24: error: ISO C++ forbids comparison between pointer and integer [-fpermissive]
if (create_iter != VM_INVALID_PROP)
^~~~~~~~~~~~~~~
make: *** [Makefile:4708: obj/tct3stm.o] Error 1

I had tried frobtads solution:

./configure --prefix=/usr CXXFLAGS="-std=c++03"

but qtads do not accept ./configure. Only:

CXXFLAGS="-std=c++03"

make the same result.

Is there any wordaround for this package?