Package Details: qtcreator-clang-git 3.4.0.rc1.r159.g6c1f270-1

Git Clone URL: (read-only)
Package Base: qtcreator-clang-git
Description: Lightweight, cross-platform integrated development environment
Upstream URL:
Licenses: LGPL
Conflicts: qtcreator, qtcreator-git
Provides: qtcreator
Submitter: None
Maintainer: yurikoles
Last Packager: yurikoles
Votes: 9
Popularity: 0.000000
First Submitted: 2012-04-19 05:53
Last Updated: 2015-06-09 18:46

Dependencies (15)

Required by (17)

Sources (3)

Latest Comments

nsf commented on 2014-02-18 12:16

I've made this PKGBUILD:

It works. Well, it was hacked from the qtcreator-git, which means you probably need other custom files from that package, hence do "packer -G qtcreator-git" to fetch the "qtcreator.desktop".

If the build fails with v8-something error, make sure you did this: "pacman -R qt5-jsbackend". Qt no longer uses v8 for its QML stuff it seems.

The rest should be ok.

H3g3m0n commented on 2014-01-17 04:51

According to a post here:

The official branch of qtcreator now has merged in clang support and just need a flag passed on build:

So it might be worth switching to the official git repo if this is the case.

Anonymous comment on 2013-03-30 13:50

Hi, could you update the package again? It's using qt5 instead of qt4 which is why when I compile it, it gives me the error of not being able to find the module QT: Script.

So change the lines

depends=('qt4>=4.8.0' 'clang>=3.2')
makedepends=('git' 'qt4-private-headers')


depends=('qt5-quick1' 'qt5-tools' 'clang>=3.2')

And it'll solve all of the problems.

Anonymous comment on 2013-03-29 22:37

Still doesn't work, for some reason I get:

fatal: Cannot update paths and switch to branch 'clang_mar2013' at the same time. Did you intend to checkout 'origin/clang_mar2013' which can not be resolved as commit?

and when I rebuild (with same PKGBUILD), it goes to compile and build qtcreator but then it gives me the error of this:

make[2]: Entering directory `/tmp/yaourt-tmp-joe/aur-qtcreator-clang-git/src/build/src/libs'
cd utils/ && ( test -f Makefile || /usr/bin/qmake /tmp/yaourt-tmp-joe/aur-qtcreator-clang-git/src/qt-creator/src/libs/utils/ -o Makefile ) && make -f Makefile
Project ERROR: Unknown module(s) in QT: script
make[2]: *** [sub-utils-make_first-ordered] Error 3
make[2]: Leaving directory `/tmp/yaourt-tmp-joe/aur-qtcreator-clang-git/src/build/src/libs'
make[1]: *** [sub-libs-make_first-ordered] Error 2
make[1]: Leaving directory `/tmp/yaourt-tmp-joe/aur-qtcreator-clang-git/src/build/src'
make: *** [sub-src-make_first-ordered] Error 2

Anonymous comment on 2013-03-29 21:56


Anonymous comment on 2013-03-29 20:49

Please update, and I had errors not being able to find qt and qt-private-headers. You should change the lines:

depends=('qt>=4.8.0' 'clang>=3.2')
makedepends=('git' 'qt-private-headers')


depends=('qt4>=4.8.0' 'clang>=3.2')
makedepends=('git' 'qt4-private-headers')

After that, I got this error:

fatal: Cannot update paths and switch to branch 'clang_mar2013' at the same time.
Did you intend to checkout 'origin/clang_feb2013' which can not be resolved as commit?
==> ERROR: A failure occurred in build().
==> ERROR: Makepkg was unable to build qtcreator-clang-git.

shuall commented on 2013-02-10 22:09

You should change the line that says "git checkout -b" to "git checkout -B". I was getting an error with the build because the branch was already there.

Anonymous comment on 2013-01-28 09:25

Anyone want to adopt this package? I don't want to maintain this any more...
Clang model branch has many bugs and performs not very well...

Anonymous comment on 2013-01-27 12:32

Update it, please. Also minimal clang version now is 3.2.

Anonymous comment on 2012-12-10 07:56

commit 9fa41be on Fri Nov 23 has bugs which will freeze qtcreator when indexing.

All comments