Package Details: qtcreator-cppcheck-plugin 4.3.0-1

Git Clone URL: https://aur.archlinux.org/qtcreator-cppcheck-plugin.git (read-only)
Package Base: qtcreator-cppcheck-plugin
Description: Qt Creator Cppcheck integration plugin
Upstream URL: http://downloads.sourceforge.net/project/qtc-cppcheck/bin/4.3.0/
Licenses: MIT
Groups: qt, qt5
Provides: qtcreator-cppcheck-plugin
Submitter: utsi
Maintainer: None
Last Packager: utsi
Votes: 8
Popularity: 0.000000
First Submitted: 2015-08-28 11:48
Last Updated: 2017-05-31 08:13

Latest Comments

1 2 Next › Last »

Shatur commented on 2018-08-16 19:23

Since version 4.4.0 precompiled binaries can be found in Github releases: https://github.com/OneMoreGres/qtc-cppcheck/releases

But in order for the plugin to work in Arch Linux, you need to build it, so you need to add a new dependency to qtcreator-src

Here is fully-working PKGBUILD with latest version (4.7.0): https://pastebin.com/tXSXxpzS

marmistrz commented on 2017-07-04 12:42

Confirmed, even with Qt 5.9

Piscolero commented on 2017-06-20 06:30

Getting the same error (qtcreator: relocation error: /usr/lib/qtcreator/plugins/libQtcCppcheck.so: symbol _ZdlPvm, version Qt_5 not defined in file libQt5Core.so.5 with link time reference) even with Qt 5.9.

marmistrz commented on 2017-05-31 18:11

The 4.3.0 binary wants Qt 5.9

qtcreator: relocation error: /usr/lib/qtcreator/plugins/libQtcCppcheck.so: symbol _ZdlPvm, version Qt_5 not defined in file libQt5Core.so.5 with link time reference

We have 5.8 in Arch

utsi commented on 2017-01-24 19:06

Please do not flag if the package is still working. Tested in QtCreator 4.2.1 and everything is fine.

marmistrz commented on 2016-12-16 13:20

I did `sudo pacman -Sd qtcreator`, then proceeded with the upgrade.

utsi commented on 2016-12-16 12:38

Huh, tricky situation, would need to see how to really fix it, but for a temporary solution (that may become permanent) I will remove the lower bound check, since is not really needed if you are running an up to date qtcreator.

You will have to go AUR update first and then main repository, since this package is holding back the upgrade. Will see if there are better solutions to this chicken and egg problem.

marmistrz commented on 2016-12-16 12:30

I'm using pacaur. There's always a problem when trying to upgrade qtcreator:

qtcreator-cppcheck-plugin: installing qtcreator (4.2.0-1) breaks dependency 'qtcreator<4.2.0'

This happens because the repository upgrade are always commited first, and once they've finished, the AUR upgrades are considered.

The pacaur developer claims that this should be handled on the AUR package side.

utsi commented on 2016-08-25 18:23

Package will get updated when new binary hits sourceforge. Not the maintainer of the binaries on SF, so a bit of patience please :)

If you need it ASAP, I recommend installing the git version.

Edit:
Updated

utsi commented on 2016-03-31 14:38

Hi, sorry didn't catch that sooner, currently using qtcreator-git :)

Added support for higher versions than 3.6, though this might mean the plugin will suddenly stop working with QtCreator 4