Package Details: qtcreator-git v4.4.0.beta1.r74.g42844215ca-1

Git Clone URL: https://aur.archlinux.org/qtcreator-git.git (read-only)
Package Base: qtcreator-git
Description: Lightweight, cross-platform integrated development environment
Upstream URL: https://www.qt.io/ide/
Licenses: GPL
Conflicts: qbs, qtcreator
Provides: qbs, qtcreator
Submitter: delor
Maintainer: rodrigo21 (hunger)
Last Packager: hunger
Votes: 28
Popularity: 0.658618
First Submitted: 2009-04-12 14:35
Last Updated: 2017-07-25 17:55

Dependencies (18)

Required by (35)

Sources (2)

Latest Comments

hunger commented on 2017-07-24 20:34

@newmentos: The URL work for me:-/ Maybe the upstream servers were down when you tried that?

@rodrigo21: Sorry, my CI has not picked up your latest change:-/

Master branch does *NOT* work with any Qbs but the one from git, so system qbs is not an option here. The build currently fails due to that for me.

Qt5-webengine is not recommended. The qtcreator package should ideally also drop that: It is huge and serves no real purpose (and leads to Creator jumping to the wrong places).

I'll push patches once my CI confirms things work again.

newmentos commented on 2017-06-15 19:15

fatal: unable to connect to code.qt.io:
code.qt.io[0: 34.253.52.112]: errno=Connection refused

tdy commented on 2017-01-21 09:48

makedepends on [extra]llvm (for /usr/bin/llvm-config)

hunger commented on 2016-04-22 07:45

Just a short heads-up: I switched the package back to the master branch.

The RC is out, which means the 4.0 branch will only get fixes backported, so master is again the more interesting target to track.

hunger commented on 2016-03-07 13:45

OK, for the time being qtcreator-git is tracking the 4.0 branch now (and qbs 1.5).

I will switch back to master for both Qt Creator and qbs once that is again where most work happens.

hunger commented on 2016-03-03 01:23

@rodrigo21: Switching to the 4.0 branch somehow breaks the qbs submodule update:-/

I'll look into that tomorrow. Too tired right now.

rodrigo21 commented on 2016-03-03 01:04

Ok, it's a good idea.

hunger commented on 2016-03-03 00:53

@rodrigo21: Most development work happens in the 4.0 branch right now as everybody is fixing bugs for the upcoming release.

Should we switch to that branch till 4.0 gets out?

hunger commented on 2016-02-07 20:54

Done. Also added a couple of optdepends.

rodrigo21 commented on 2016-02-07 20:10

Just update the license field. I think it's ok.

All comments